aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-09 08:30:05 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:51 +0200
commit40dc443da8fc9c49ec46f732cf3264d7313f68ce (patch)
tree303c5576cc1a3054d2b118d44e0ab9bfd042f8c6 /meta-oe/recipes-support
parentbd4b6d1e1af0193725919f938f8e24c25b373395 (diff)
downloadmeta-openembedded-contrib-40dc443da8fc9c49ec46f732cf3264d7313f68ce.tar.gz
sdparm: split sdparm-scripts subpkg
Bash scripts: packages-split/sdparm/usr/bin/sas_disk_blink:#!/bin/bash packages-split/sdparm/usr/bin/scsi_ch_swp:#!/bin/bash The sdparm is a ~150K executable so making it pull in bash at >1000K isn't good for embedded systems. Neither script appears to be essential, so put them in sdparm-scripts as Randy suggested. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/sdparm/sdparm_1.08.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sdparm/sdparm_1.08.bb b/meta-oe/recipes-support/sdparm/sdparm_1.08.bb
index 713e451fa9..b603a56824 100644
--- a/meta-oe/recipes-support/sdparm/sdparm_1.08.bb
+++ b/meta-oe/recipes-support/sdparm/sdparm_1.08.bb
@@ -11,7 +11,13 @@ SRC_URI = "http://sg.danny.cz/sg/p/${BPN}-${PV}.tgz \
file://make-sysroot-work.patch \
"
+PACKAGES =+ "${PN}-scripts"
+RDEPENDS_${PN}-scripts += "bash ${PN}"
+
SRC_URI[md5sum] = "be5786f37499018ef44f409597c92d42"
SRC_URI[sha256sum] = "376b78a414b1a9c47f3f13dbeb963e7a3ec7be126f83927d6856b5f7ac425e57"
inherit autotools
+
+# Put the bash scripts to ${PN}-scripts
+FILES_${PN}-scripts = "${bindir}/sas_disk_blink ${bindir}/scsi_ch_swp"