aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKlauer, Daniel <Daniel.Klauer@gin.de>2019-08-28 14:43:35 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-29 09:06:54 -0700
commit7d44b3d7858adb4db8604bf408366432081bfd4b (patch)
treeab438bbbc6fd19f5c22aed48e5ed9e0128349e13 /meta-oe/recipes-support
parentdab0e5421fb36bc49a1fd59ff915d28782fb451b (diff)
downloadmeta-openembedded-contrib-7d44b3d7858adb4db8604bf408366432081bfd4b.tar.gz
sjf2410-linux-native: Fix do_deploy sstate caching
deploy.bbclass requires do_deploy to copy files to DEPLOYDIR (sstate input dir) instead of DEPLOY_DIR_TOOLS (sstate output dir), otherwise the sstate caching does not work. Signed-off-by: Daniel Klauer <daniel.klauer@gin.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
index c56c8b9dd8..9e609c4dd8 100644
--- a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
+++ b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
@@ -27,8 +27,7 @@ do_install() {
}
do_deploy() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV}
+ install -m 0755 sjf2410 ${DEPLOYDIR}/sjf2410-${PV}
}
addtask deploy before do_build after do_install