aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2011-12-21 06:01:41 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-22 08:49:16 +0100
commit16da7fbd7b7a41c51e6c650e133f53b7210016e3 (patch)
tree8810ee0183bc7e12dcc4e91327aafe090c0d3d63 /meta-oe/recipes-support
parent8b08e151645d19d2940b6f83c7626087f4ac874f (diff)
downloadmeta-openembedded-contrib-16da7fbd7b7a41c51e6c650e133f53b7210016e3.tar.gz
ipsec-tools: add version 0.7.2
IPsec-Tools is a port of KAME's IPsec utilities to the Linux IPsec implementation. Signed-off-by: Zhenhua Luo <b19537@freescale.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch14
-rw-r--r--meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc51
-rw-r--r--meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb7
3 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch b/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch
new file mode 100644
index 0000000000..6b9c39b6de
--- /dev/null
+++ b/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch
@@ -0,0 +1,14 @@
+Taken from pld-linux.org:
+http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/ipsec-tools/ipsec-tools-install.patch
+
+--- ipsec-tools-0.7.2/src/racoon/Makefile.am~ 2008-07-23 13:48:40.000000000 +0200
++++ ipsec-tools-0.7.2/src/racoon/Makefile.am 2009-07-04 01:43:48.148433975 +0200
+@@ -3,7 +3,7 @@
+ sbin_PROGRAMS = racoon racoonctl plainrsa-gen
+ noinst_PROGRAMS = eaytest
+ include_racoon_HEADERS = racoonctl.h var.h vmbuf.h misc.h gcmalloc.h admin.h \
+- schedule.h sockmisc.h vmbuf.h isakmp_var.h isakmp.h isakmp_xauth.h \
++ schedule.h sockmisc.h isakmp_var.h isakmp.h isakmp_xauth.h \
+ isakmp_cfg.h isakmp_unity.h ipsec_doi.h evt.h
+ lib_LTLIBRARIES = libracoon.la
+
diff --git a/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc b/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc
new file mode 100644
index 0000000000..caf2b0b71e
--- /dev/null
+++ b/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc
@@ -0,0 +1,51 @@
+DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \
+Linux-2.6 IPsec implementation."
+HOMEPAGE = "http://ipsec-tools.sourceforge.net/"
+SECTION = "console/network"
+LICENSE = "BSD"
+DEPENDS = "virtual/kernel openssl readline flex"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2;name=ipsec-tools-${PV}"
+
+inherit autotools
+
+# Options:
+# --enable-adminport enable admin port
+# --enable-rc5 enable RC5 encryption (patented)
+# --enable-idea enable IDEA encryption (patented)
+# --enable-gssapi enable GSS-API authentication
+# --enable-hybrid enable hybrid, both mode-cfg and xauth support
+# --enable-frag enable IKE fragmentation payload support
+# --enable-stats enable statistics logging function
+# --enable-dpd enable dead peer detection
+# --enable-samode-unspec enable to use unspecified a mode of SA
+# --disable-ipv6 disable ipv6 support
+# --enable-natt enable NAT-Traversal (yes/no/kernel)
+# --enable-natt-versions=list list of supported NAT-T versions delimited by coma.
+# --with-kernel-headers=/lib/modules/<uname>/build/include
+# where your Linux Kernel headers are installed
+# --with-readline support readline input (yes by default)
+# --with-flex use directiory (default: no)
+# --with-flexlib=<LIB> specify flex library.
+# --with-openssl=DIR specify OpenSSL directory
+# --with-libradius=DIR specify libradius path (like/usr/pkg)
+# --with-libpam=DIR specify libpam path (like/usr/pkg)
+#
+# Note: if you give it the actual kernel headers it won't build, it actually
+# needs to point at the linux-libc-headers version of the kernel headers.
+#
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \
+ --with-readline \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+ --without-libradius \
+ --without-gssapi \
+ --without-libpam \
+ --disable-security-context"
+
+# See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530527
+CFLAGS += "-fno-strict-aliasing"
+
+# Sometimes it attempts to use y.tab.c before it is actually
+# generated. Note that the failure case is very rare, but it does
+# happen.
+PARALLEL_MAKE = ""
diff --git a/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb b/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb
new file mode 100644
index 0000000000..270d77eb52
--- /dev/null
+++ b/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb
@@ -0,0 +1,7 @@
+require ipsec-tools.inc
+
+LIC_FILES_CHKSUM = "file://Makefile.in;endline=14;md5=c73d05590728997bfbab5c671ed38366"
+
+SRC_URI += "file://ipsec-tools-install.patch"
+SRC_URI[ipsec-tools-0.7.2.md5sum] = "72861f005746ee27984b2ee715ecc629"
+SRC_URI[ipsec-tools-0.7.2.sha256sum] = "08722ff6c62de3e042fef337454f03622a79053108d6dcc686c9c854f9f9e031"