aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-11-20 21:31:49 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:51:37 -0800
commit4c00e5fed9532fe6ee71ce96b0124fc234b44d4e (patch)
treeec74c3e49a545e37a85befe3d7f970304af5516c /meta-oe/recipes-support
parentb77cc676916e7cf06e5a80081aac52a7bdc7d3a9 (diff)
downloadmeta-openembedded-contrib-4c00e5fed9532fe6ee71ce96b0124fc234b44d4e.tar.gz
recipes: rename distro_features_check to features_check
Avoid warning due to the class rename in OE-Core. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb2
-rw-r--r--meta-oe/recipes-support/colord/colord.bb2
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb2
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.16.bb2
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin-otr_4.0.2.bb2
-rw-r--r--meta-oe/recipes-support/remmina/remmina_1.3.6.bb2
-rw-r--r--meta-oe/recipes-support/synergy/synergy_git.bb2
-rw-r--r--meta-oe/recipes-support/toscoterm/toscoterm_git.bb2
-rw-r--r--meta-oe/recipes-support/udisks/udisks2_git.bb2
-rw-r--r--meta-oe/recipes-support/uim/uim_1.8.8.bb2
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.11.bb2
-rw-r--r--meta-oe/recipes-support/utouch/utouch-mtview_git.bb2
-rw-r--r--meta-oe/recipes-support/xorg-xrdp/xorgxrdp_0.2.5.bb2
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb2
14 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index 30d41a16e6..9362a5c110 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = " \
file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
"
-inherit autotools pkgconfig python3native lib_package distro_features_check
+inherit autotools pkgconfig python3native lib_package features_check
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-support/colord/colord.bb b/meta-oe/recipes-support/colord/colord.bb
index aa5d1d129b..df86708e2b 100644
--- a/meta-oe/recipes-support/colord/colord.bb
+++ b/meta-oe/recipes-support/colord/colord.bb
@@ -1,6 +1,6 @@
require ${BPN}.inc
-inherit meson gobject-introspection gsettings gettext bash-completion systemd distro_features_check useradd
+inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
# polkit and gobject-introspection are mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
index ec9e04bed6..7ad4ac70a9 100644
--- a/meta-oe/recipes-support/fltk/fltk.bb
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -2,7 +2,7 @@ require ${BPN}.inc
DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
-inherit distro_features_check binconfig lib_package gtk-icon-cache mime
+inherit features_check binconfig lib_package gtk-icon-cache mime
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI += "file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch"
diff --git a/meta-oe/recipes-support/links/links-x11_2.16.bb b/meta-oe/recipes-support/links/links-x11_2.16.bb
index f55a6fc7b3..90fa200845 100644
--- a/meta-oe/recipes-support/links/links-x11_2.16.bb
+++ b/meta-oe/recipes-support/links/links-x11_2.16.bb
@@ -25,7 +25,7 @@ require links.inc
DEPENDS += "virtual/libx11"
RCONFLICTS_${PN} = "links"
-inherit distro_features_check
+inherit features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.2.bb b/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.2.bb
index 5a21cd3fc9..04133c1b3d 100644
--- a/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.2.bb
+++ b/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.2.bb
@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "f4b59eef4a94b1d29dbe0c106dd00cdc630e47f18619fc754e5afbf572
FILES_${PN} = "${libdir}/pidgin/*"
-inherit autotools pkgconfig distro_features_check
+inherit autotools pkgconfig features_check
diff --git a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
index 82b803a4d2..14fbc94b21 100644
--- a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
+++ b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
@@ -18,7 +18,7 @@ SRC_URI[sha256sum] = "fbed745438bb0c21467b60cbd67c8148a9289b5ebc7482d06db443bea5
S = "${WORKDIR}/Remmina-v${PV}"
-inherit cmake distro_features_check
+inherit cmake features_check
# depends on avahi-ui with this restriction
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
diff --git a/meta-oe/recipes-support/synergy/synergy_git.bb b/meta-oe/recipes-support/synergy/synergy_git.bb
index f5518bd8c1..dba89d181c 100644
--- a/meta-oe/recipes-support/synergy/synergy_git.bb
+++ b/meta-oe/recipes-support/synergy/synergy_git.bb
@@ -17,7 +17,7 @@ PV = "1.10.1+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit cmake distro_features_check
+inherit cmake features_check
EXTRA_OECMAKE += "-DSYNERGY_BUILD_LEGACY_GUI=OFF"
diff --git a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
index 879b67b7f5..aba485e1a4 100644
--- a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
+++ b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/OSSystems/toscoterm.git"
S = "${WORKDIR}/git"
-inherit distro_features_check gitpkgv pkgconfig
+inherit features_check gitpkgv pkgconfig
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-support/udisks/udisks2_git.bb b/meta-oe/recipes-support/udisks/udisks2_git.bb
index 9c9e5e52a6..f0aad95384 100644
--- a/meta-oe/recipes-support/udisks/udisks2_git.bb
+++ b/meta-oe/recipes-support/udisks/udisks2_git.bb
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
CVE_PRODUCT = "udisks"
-inherit autotools systemd gtk-doc gobject-introspection gettext distro_features_check
+inherit autotools systemd gtk-doc gobject-introspection gettext features_check
REQUIRED_DISTRO_FEATURES = "polkit"
diff --git a/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-oe/recipes-support/uim/uim_1.8.8.bb
index 8948ebf30f..c1136cd998 100644
--- a/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -25,7 +25,7 @@ LEAD_SONAME = "libuim.so.1"
COMPATIBLE_HOST_riscv64 = "null"
COMPATIBLE_HOST_riscv32 = "null"
-inherit distro_features_check autotools pkgconfig gettext qemu gtk-immodules-cache
+inherit features_check autotools pkgconfig gettext qemu gtk-immodules-cache
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-support/upower/upower_0.99.11.bb b/meta-oe/recipes-support/upower/upower_0.99.11.bb
index c4cc627116..6408417920 100644
--- a/meta-oe/recipes-support/upower/upower_0.99.11.bb
+++ b/meta-oe/recipes-support/upower/upower_0.99.11.bb
@@ -10,7 +10,7 @@ SRC_URI = " \
SRC_URI[md5sum] = "abe6acb617f11f2e8dbd9846fcf86e24"
SRC_URI[sha256sum] = "64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef"
-inherit autotools pkgconfig gettext gobject-introspection systemd distro_features_check
+inherit autotools pkgconfig gettext gobject-introspection systemd features_check
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
diff --git a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
index 8cb180dc8b..5f07bf28ee 100644
--- a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://bitmath.org/code/mtview/"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=4c61b8950dc1aab4d2aa7c2ae6b1cfb3"
-inherit autotools pkgconfig distro_features_check
+inherit autotools pkgconfig features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-support/xorg-xrdp/xorgxrdp_0.2.5.bb b/meta-oe/recipes-support/xorg-xrdp/xorgxrdp_0.2.5.bb
index 0bdafdf3bd..481e7303b3 100644
--- a/meta-oe/recipes-support/xorg-xrdp/xorgxrdp_0.2.5.bb
+++ b/meta-oe/recipes-support/xorg-xrdp/xorgxrdp_0.2.5.bb
@@ -7,7 +7,7 @@ inherit autotools pkgconfig
DEPENDS = "virtual/libx11 xserver-xorg xrdp nasm-native"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 pam"
SRC_URI = "git://github.com/neutrinolabs/xorgxrdp.git"
diff --git a/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb b/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
index 75caf8d6bb..deda0fd1b5 100644
--- a/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
+++ b/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
@@ -4,7 +4,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=72cfbe4e7bd33a0a1de9630c91195c21 \
"
-inherit distro_features_check autotools pkgconfig useradd systemd
+inherit features_check autotools pkgconfig useradd systemd
DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native"