aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:46 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit7b32361bd7e2a4a65123f90dcc1e9ff9e90ca2ba (patch)
tree4f20e115f1690e41cac57b3d843dde2bb3ad434e /meta-oe/recipes-support
parente50762e09b1624910daaf5bb28c4584c291b089b (diff)
downloadmeta-openembedded-contrib-7b32361bd7e2a4a65123f90dcc1e9ff9e90ca2ba.tar.gz
open-vm-tools: style changes
Various cosmetic changes to make the recipe match the style guide: http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index 906eaba644..4ab2820c1c 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -9,7 +9,8 @@
# in meta-openembedded by agreement of the author (Diego Dompe).
#
-DECRIPTION = "open-vm-tools"
+SUMMARY = "Tools to enhance VMWare guest integration and performance"
+HOMEPAGE = "https://github.com/vmware/open-vm-tools"
SECTION = "vmware-tools"
LICENSE = "LGPLv2.1 & GPLv2 & BSD & CDDLv1"
@@ -32,7 +33,6 @@ SRCREV = "854c0bb374612f7e633b448ca273f970f154458b"
S = "${WORKDIR}/git/open-vm-tools"
DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps"
-RDEPENDS_${PN} = "util-linux libdnet"
# open-vm-tools is supported only on x86.
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
@@ -53,18 +53,24 @@ PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
# fuse gets implicitly detected; there is no --without-fuse option.
PACKAGECONFIG[fuse] = ",,fuse"
-CFLAGS += '-Wno-error=deprecated-declarations'
+CFLAGS += "-Wno-error=deprecated-declarations"
-FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \
- /usr/lib/open-vm-tools/plugins/common/lib*.so \
- ${sysconfdir}/vmware-tools/tools.conf"
+FILES_${PN} += "\
+ /usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \
+ /usr/lib/open-vm-tools/plugins/common/lib*.so \
+ ${sysconfdir}/vmware-tools/tools.conf \
+ "
FILES_${PN}-locale += "/usr/share/open-vm-tools/messages"
FILES_${PN}-dev += "/usr/lib/open-vm-tools/plugins/common/lib*.la"
-FILES_${PN}-dbg += "/usr/lib/open-vm-tools/plugins/common/.debug \
- /usr/lib/open-vm-tools/plugins/vmsvc/.debug"
+FILES_${PN}-dbg += "\
+ /usr/lib/open-vm-tools/plugins/common/.debug \
+ /usr/lib/open-vm-tools/plugins/vmsvc/.debug \
+ "
CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
+RDEPENDS_${PN} = "util-linux libdnet fuse"
+
do_install_append() {
ln -sf /usr/sbin/mount.vmhgfs ${D}/sbin/mount.vmhgfs
install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools