aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/yaml-cpp
diff options
context:
space:
mode:
authorRamon Fried <rfried.dev@gmail.com>2020-12-25 23:19:08 +0200
committerKhem Raj <raj.khem@gmail.com>2020-12-28 22:27:41 -0800
commit4090ca3b5be48b4df4c526cf0b66bf02ee2a8058 (patch)
tree1859f815f1309516fbf13c63b1d2aa2b8e1c00e9 /meta-oe/recipes-support/yaml-cpp
parent2c7bbea253f473b6aa35b9263311a83acd4d9d95 (diff)
downloadmeta-openembedded-contrib-4090ca3b5be48b4df4c526cf0b66bf02ee2a8058.tar.gz
yaml-cpp: add new recipe
yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec. Signed-off-by: Ramon Fried <rfried.dev@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/yaml-cpp')
-rw-r--r--meta-oe/recipes-support/yaml-cpp/yaml-cpp_0.6.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/yaml-cpp/yaml-cpp_0.6.3.bb b/meta-oe/recipes-support/yaml-cpp/yaml-cpp_0.6.3.bb
new file mode 100644
index 0000000000..9d359d6244
--- /dev/null
+++ b/meta-oe/recipes-support/yaml-cpp/yaml-cpp_0.6.3.bb
@@ -0,0 +1,17 @@
+SUMMARY = "yaml-cpp parser and emitter library"
+DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec."
+HOMEPAGE = "https://github.com/jbeder/yaml-cpp"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
+
+# yaml-cpp releases are stored as archive files in github.
+# download the exact revision of release
+SRC_URI = "git://github.com/jbeder/yaml-cpp.git"
+SRCREV = "9a3624205e8774953ef18f57067b3426c1c5ada6"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DYAML_CPP_BUILD_TESTS=OFF -DYAML_BUILD_SHARED_LIBS=ON -DYAML_CPP_BUILD_TOOLS=OFF"