aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xrdp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-22 21:18:43 -0800
committerKhem Raj <raj.khem@gmail.com>2020-12-23 22:47:02 -0800
commitfa9d118550be5e5c7b1d61b1e1e92828f48b55ff (patch)
treec5b1aaf04a302606033bba9993e81b8d165cc470 /meta-oe/recipes-support/xrdp
parentdb3aab1e47268ae8e919e0b94c2021139031f76e (diff)
downloadmeta-openembedded-contrib-fa9d118550be5e5c7b1d61b1e1e92828f48b55ff.tar.gz
xrdp: Upgrade to 0.9.14
Drop redundant setting of PV in recipe Fix build on riscv and musl Do not install xrdp.sh, it does not exist anymore Fix build with gcc 9+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xrdp')
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch28
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch30
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch28
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb (renamed from meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb)19
4 files changed, 95 insertions, 10 deletions
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch
new file mode 100644
index 0000000000..5b9315cfb4
--- /dev/null
+++ b/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch
@@ -0,0 +1,28 @@
+From 9de23a9199d26e64ab6b5be2bb74f260200b2dc5 Mon Sep 17 00:00:00 2001
+From: matt335672 <30179339+matt335672@users.noreply.github.com>
+Date: Fri, 21 Aug 2020 12:20:31 +0100
+Subject: [PATCH] Fixed compiler warnings about snprintf truncations
+
+Upstream-Status: Backport [https://github.com/neutrinolabs/xrdp/pull/1659]
+---
+ common/log.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/common/log.c b/common/log.c
+index 4a0bd2f3..8686789d 100644
+--- a/common/log.c
++++ b/common/log.c
+@@ -555,9 +555,7 @@ log_message(const enum logLevels lvl, const char *msg, ...)
+ now_t = time(&now_t);
+ now = localtime(&now_t);
+
+- snprintf(buff, 21, "[%.4d%.2d%.2d-%.2d:%.2d:%.2d] ", now->tm_year + 1900,
+- now->tm_mon + 1, now->tm_mday, now->tm_hour, now->tm_min,
+- now->tm_sec);
++ strftime(buff, 21, "[%Y%m%d-%H:%M:%S] ", now);
+
+ internal_log_lvl2str(lvl, buff + 20);
+
+--
+2.29.2
+
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch
new file mode 100644
index 0000000000..b06077bf02
--- /dev/null
+++ b/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch
@@ -0,0 +1,30 @@
+From c8d3df40ece7d659ccc8212b18de916d28f4398a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 22 Dec 2020 23:10:52 -0800
+Subject: [PATCH] correct the location of errno.h
+
+Fixes build on musl
+
+Upstream-Status: Submitted [https://github.com/neutrinolabs/xrdp/pull/1761]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ sesman/chansrv/sound.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sesman/chansrv/sound.c b/sesman/chansrv/sound.c
+index b0480d33..45e17307 100644
+--- a/sesman/chansrv/sound.c
++++ b/sesman/chansrv/sound.c
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+-#include <sys/errno.h>
++#include <errno.h>
+ #include <signal.h>
+ #include <sys/un.h>
+
+--
+2.29.2
+
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch
new file mode 100644
index 0000000000..4cd26df04c
--- /dev/null
+++ b/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch
@@ -0,0 +1,28 @@
+From 229206aa5e55a6e26a074a54a1b50139ab794b36 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 22 Dec 2020 23:01:13 -0800
+Subject: [PATCH] riscv doesn't require pointers to be aligned
+
+Upstream-Status: Submitted [https://github.com/neutrinolabs/xrdp/pull/1761]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ common/arch.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/common/arch.h b/common/arch.h
+index ccccfa5a..8c2ac1a4 100644
+--- a/common/arch.h
++++ b/common/arch.h
+@@ -84,7 +84,8 @@ typedef int bool_t;
+ #define NEED_ALIGN
+ #elif defined(__x86__) || defined(__x86_64__) || \
+ defined(__AMD64__) || defined(_M_IX86) || defined (_M_AMD64) || \
+- defined(__i386__) || defined(__aarch64__)
++ defined(__i386__) || defined(__aarch64__) || \
++ defined(__riscv)
+ #define NO_NEED_ALIGN
+ #else
+ #warning unknown arch
+--
+2.29.2
+
diff --git a/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb b/meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb
index deda0fd1b5..078e23c6ed 100644
--- a/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
+++ b/meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb
@@ -10,15 +10,15 @@ DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native"
REQUIRED_DISTRO_FEATURES = "x11 pam"
-SRC_URI = "git://github.com/neutrinolabs/xrdp.git \
+SRC_URI = "git://github.com/neutrinolabs/xrdp.git;branch=devel \
file://xrdp.sysconfig \
file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \
file://0001-Fix-the-compile-error.patch \
+ file://0001-riscv-doesn-t-require-pointers-to-be-aligned.patch \
+ file://0001-correct-the-location-of-errno.h.patch \
+ file://0001-Fixed-compiler-warnings-about-snprintf-truncations.patch \
"
-
-SRCREV = "1e4b03eb3c9aa7173de251a328c93c073dcc0fca"
-
-PV = "0.9.11"
+SRCREV = "1469d659dbccd6d042ac44f0afc4e1309788dc9d"
S = "${WORKDIR}/git"
@@ -52,15 +52,15 @@ do_compile_prepend() {
do_install_append() {
- install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}
install -d ${D}${sysconfdir}/xrdp
install -d ${D}${sysconfdir}/xrdp/pam.d
install -d ${D}${sysconfdir}/sysconfig/xrdp
-
+
# deal with systemd unit files
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${S}/instfiles/xrdp.service.in ${D}${systemd_unitdir}/system/xrdp.service
- install -m 0644 ${S}/instfiles/xrdp-sesman.service.in ${D}${systemd_unitdir}/system/xrdp-sesman.service
+ install -m 0644 ${S}/instfiles/xrdp-sesman.service.in ${D}${systemd_unitdir}/system/xrdp-sesman.service
sed -i -e 's,@localstatedir@,${localstatedir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
sed -i -e 's,@sysconfdir@,${sysconfdir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
sed -i -e 's,@sbindir@,${sbindir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
@@ -70,7 +70,6 @@ do_install_append() {
install -m 0644 ${S}/sesman/startwm.sh ${D}${sysconfdir}/xrdp/
install -m 0644 ${S}/xrdp/xrdp.ini.in ${D}${sysconfdir}/xrdp/
install -m 0644 ${S}/xrdp/xrdp_keyboard.ini ${D}${sysconfdir}/xrdp/
- install -m 0644 ${S}/instfiles/xrdp.sh ${D}${sysconfdir}/xrdp/
install -m 0644 ${S}/keygen/openssl.conf ${D}${sysconfdir}/xrdp/
install -m 0644 ${WORKDIR}/xrdp.sysconfig ${D}${sysconfdir}/sysconfig/xrdp/
chown xrdp:xrdp ${D}${sysconfdir}/xrdp
@@ -92,6 +91,6 @@ pkg_postinst_${PN}() {
-out ${sysconfdir}/xrdp/cert.pem \
-config ${sysconfdir}/xrdp/openssl.conf >/dev/null 2>&1
chmod 400 ${sysconfdir}/xrdp/key.pem
- fi
+ fi
fi
}