aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xfsprogs
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/xfsprogs
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/xfsprogs')
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb42
1 files changed, 21 insertions, 21 deletions
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
index ef5224b5f0..ba3490d1c3 100644
--- a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
@@ -8,8 +8,8 @@ DEPENDS = "util-linux"
PR = "r1"
SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \
- file://remove-install-as-user.patch \
- file://drop-configure-check-for-aio.patch \
+ file://remove-install-as-user.patch \
+ file://drop-configure-check-for-aio.patch \
"
SRC_URI[md5sum] = "f70b2e7200d4c29f0af1cf70e7be1db6"
@@ -27,16 +27,16 @@ FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
EXTRA_OECONF = "--enable-gettext=no"
do_configure () {
- # Prevent Makefile from calling configure without arguments,
- # when do_configure gets called for a second time.
- rm -f include/builddefs include/platform_defs.h
- # Recreate configure script.
- rm -f configure
- oe_runmake configure
- # Configure.
- export DEBUG="-DNDEBUG"
- gnu-configize --force
- oe_runconf
+ # Prevent Makefile from calling configure without arguments,
+ # when do_configure gets called for a second time.
+ rm -f include/builddefs include/platform_defs.h
+ # Recreate configure script.
+ rm -f configure
+ oe_runmake configure
+ # Configure.
+ export DEBUG="-DNDEBUG"
+ gnu-configize --force
+ oe_runconf
}
LIBTOOL = "${HOST_SYS}-libtool"
@@ -45,13 +45,13 @@ TARGET_CC_ARCH += "${LDFLAGS}"
PARALLEL_MAKE = ""
do_install () {
- export DIST_ROOT=${D}
- oe_runmake install
- # needed for xfsdump
- oe_runmake install-dev
- rm ${D}${base_libdir}/libhandle.a
- rm ${D}${base_libdir}/libhandle.la
- rm ${D}${base_libdir}/libhandle.so
- rm ${D}${libdir}/libhandle.so
- ln -s ../..${base_libdir}/libhandle.so.1 ${D}${libdir}/libhandle.so
+ export DIST_ROOT=${D}
+ oe_runmake install
+ # needed for xfsdump
+ oe_runmake install-dev
+ rm ${D}${base_libdir}/libhandle.a
+ rm ${D}${base_libdir}/libhandle.la
+ rm ${D}${base_libdir}/libhandle.so
+ rm ${D}${libdir}/libhandle.so
+ ln -s ../..${base_libdir}/libhandle.so.1 ${D}${libdir}/libhandle.so
}