aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/websocketpp
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2020-01-10 15:33:17 +0100
committerKhem Raj <raj.khem@gmail.com>2020-01-10 12:34:08 -0800
commit1206a34009c1ff08bde075fad6900a87364c3dbc (patch)
tree63edfb98b3a7426f7ef596ac8dbf35d62097ac67 /meta-oe/recipes-support/websocketpp
parent425ae63835dbfcfe5d80ab4a9897e0b97b7846ce (diff)
downloadmeta-openembedded-contrib-1206a34009c1ff08bde075fad6900a87364c3dbc.tar.gz
websocketpp: also install examples in a new -examples subpackage
Thanks to Khem Raj for the suggestion, the location is similar to the one used by Debian packaging Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/websocketpp')
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
index 8a2a3e1b8b..4303f24738 100644
--- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
+++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
@@ -30,3 +30,12 @@ SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7"
S = "${WORKDIR}/git"
inherit cmake
+
+PACKAGES =+ "${PN}-examples"
+
+FILES_${PN}-examples = "${docdir}"
+
+do_install_append() {
+ install -d ${D}${docdir}/${BPN}
+ cp -R ${S}/examples ${D}${docdir}/${BPN}
+}