aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2020-01-09 11:36:51 +0100
committerArmin Kuster <akuster808@gmail.com>2020-01-19 09:01:43 -0800
commiteb8090f27afb865878a04aaeff6caac34abdbac0 (patch)
tree189062942ae0bced4d141bcebc3de369195b0421 /meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
parent636660b7b2431da724d391d237d3680a72470121 (diff)
downloadmeta-openembedded-contrib-eb8090f27afb865878a04aaeff6caac34abdbac0.tar.gz
websocketpp: add various upstream accepted and proposed patches to fix various issues, including:
- build failure with boost 1.71 - bad installation of header files correct version on some OSes. - fix version minor number - fix Scons script not being Python3 ready - build examples and tests only if ptest is enabled in DISTRO_FEATURES - do not depend on websocketpp from -dev package, because this is an header only dev package for now Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 7cd26041725e57dd0680767a513955193e1f0d63) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb')
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
index 05f14d2f42..8a2a3e1b8b 100644
--- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
+++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
@@ -3,14 +3,27 @@ SECTION = "libs/network"
HOMEPAGE = "https://github.com/zaphoyd/websocketpp"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea"
-DEPENDS = "openssl boost zlib"
+
+DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} "
SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
file://0001-Replace-make_shared-with-new-in-some-cases.patch \
file://0002-Fix-missed-entries-fix-testing.patch \
file://0001-cmake-Use-GNUInstallDirs.patch \
+ file://842.patch \
+ file://771.patch \
+ file://855.patch \
+ file://857.patch \
"
+EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} "
+
+# this is an header only library, do not depend on the main package
+RDEPENDS_${PN}-dev = ""
+
+# to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this:
+# TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev"
+
# tag 0.8.1
SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7"