aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uthash/uthash_2.0.2.bb
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-12 12:29:41 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-17 13:26:24 -0800
commit4f9081e53c81270422782b46bcc62ee93260a740 (patch)
tree1104527da28a30440211bc2790883014005e9839 /meta-oe/recipes-support/uthash/uthash_2.0.2.bb
parent9560fca3ae9bf7d519c7bdc8080b1068b6e309ef (diff)
downloadmeta-openembedded-contrib-4f9081e53c81270422782b46bcc62ee93260a740.tar.gz
uthash: update to v2.0.2
- the license has changed to BSD-1-Clause - the main package is empty (as this only provides header files), so the -dev package must not depend on the main package Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uthash/uthash_2.0.2.bb')
-rw-r--r--meta-oe/recipes-support/uthash/uthash_2.0.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uthash/uthash_2.0.2.bb b/meta-oe/recipes-support/uthash/uthash_2.0.2.bb
new file mode 100644
index 0000000000..8a6887ef06
--- /dev/null
+++ b/meta-oe/recipes-support/uthash/uthash_2.0.2.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Hash table and linked list for C structures"
+DESCRIPTION = " uthash-dev provides a hash table implementation using C preprocessor macros.\n\
+ This package also includes:\n\
+ * utlist.h provides linked list macros for C structures\n\
+ * utarray.h implements dynamic arrays using macros\n\
+ * utstring.h implements a basic dynamic string\n\
+"
+HOMEPAGE = "https://troydhanson.github.io/uthash/"
+SECTION = "base"
+LICENSE = "BSD-1-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5cc1f1e4c71f19f580458586756c02b4"
+
+SRC_URI = "https://github.com/troydhanson/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
+UPSTREAM_CHECK_URI = "https://github.com/troydhanson/${BPN}/releases"
+
+SRC_URI[md5sum] = "d08632a58674274c9cd87e2930f5696a"
+SRC_URI[sha256sum] = "34a31d51dd7a839819cecd6f46049b4ffe031d7f3147d9a042f5504fdb1348d1"
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -dm755 ${D}${includedir}
+ install -m0644 src/*.h ${D}${includedir}
+}
+
+# The main package is empty and non-existent, so -dev
+# should not depend on it...
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native"