aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/upower/upower_0.99.7.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-23 23:45:29 +0100
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit3c468473ded31fe7e88b4da09477e60dceed9180 (patch)
tree86c8af2646bfddfb802d6d5fdfcfe789605556ad /meta-oe/recipes-support/upower/upower_0.99.7.bb
parent52492e67fcb2298c5a50c66268d1e4a83ef74228 (diff)
downloadmeta-openembedded-contrib-3c468473ded31fe7e88b4da09477e60dceed9180.tar.gz
upower: update 0.99.5 -> 0.99.7
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/upower/upower_0.99.7.bb')
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.7.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/upower/upower_0.99.7.bb b/meta-oe/recipes-support/upower/upower_0.99.7.bb
new file mode 100644
index 0000000000..973fbe771e
--- /dev/null
+++ b/meta-oe/recipes-support/upower/upower_0.99.7.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
+
+DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib polkit"
+
+SRC_URI = "http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "236bb439d9ff1151450b3d8582399532"
+SRC_URI[sha256sum] = "24bcc2f6ab25a2533bac70b587bcb019e591293076920f5b5e04bdedc140a401"
+
+inherit autotools pkgconfig gettext gobject-introspection systemd
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
+PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
+ --without-systemdutildir --without-systemdsystemunitdir,systemd"
+
+EXTRA_OECONF = " --with-backend=linux"
+
+SYSTEMD_SERVICE_${PN} = "upower.service"
+# don't start on boot by default - dbus does that on demand
+SYSTEMD_AUTO_ENABLE = "disable"
+
+do_configure_prepend() {
+ sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+RDEPENDS_${PN} += "dbus"
+RRECOMMENDS_${PN} += "pm-utils"
+FILES_${PN} += "${datadir}/dbus-1/ \
+ ${datadir}/polkit-1/ \
+ ${base_libdir}/udev/* \
+"