aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/upower/upower_0.99.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-09 18:42:32 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:59 +0200
commite22b9e01e0101b9c8ebfda8e6f3645230a2ceceb (patch)
tree62251f35b1b0357403daa078b36ace02c6a12b75 /meta-oe/recipes-support/upower/upower_0.99.4.bb
parentd95a980fe1aa241138500866ffa4099e610fe9bc (diff)
downloadmeta-openembedded-contrib-e22b9e01e0101b9c8ebfda8e6f3645230a2ceceb.tar.gz
upower: update to version 0.99.4
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/upower/upower_0.99.4.bb')
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/upower/upower_0.99.4.bb b/meta-oe/recipes-support/upower/upower_0.99.4.bb
new file mode 100644
index 0000000000..861f17ccf3
--- /dev/null
+++ b/meta-oe/recipes-support/upower/upower_0.99.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
+
+DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib polkit"
+
+SRC_URI = "http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "78800e1ac7f92b24aabdf433e38f75d2"
+SRC_URI[sha256sum] = "9ca325a6ccef505529b268ebbbd9becd0ce65a65f6ac7ee31e2e5b17648037b0"
+
+inherit autotools pkgconfig gettext gobject-introspection
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
+
+EXTRA_OECONF = " --with-backend=linux"
+
+do_configure_prepend() {
+ sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+RDEPENDS_${PN} += "dbus"
+RRECOMMENDS_${PN} += "pm-utils"
+FILES_${PN} += "${datadir}/dbus-1/ \
+ ${datadir}/polkit-1/ \
+ ${base_libdir}/udev/* \
+"
+
+FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
+
+
+