aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/unicode-ucd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-10-29 02:02:52 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-01 07:48:55 -0700
commita8ed30979fca62381740ae3c2ced2c5a63bd433f (patch)
treef0ebaea8300d2245b58fcd5cf4ace8a0d5862d13 /meta-oe/recipes-support/unicode-ucd
parentb29797ba4bd89208b572365ddf09b714af03ea46 (diff)
downloadmeta-openembedded-contrib-a8ed30979fca62381740ae3c2ced2c5a63bd433f.tar.gz
unicode-ucd: initial add 12.1.0
It is a build dependency for ibus Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/unicode-ucd')
-rw-r--r--meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb b/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb
new file mode 100644
index 0000000000..88a116f634
--- /dev/null
+++ b/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "C++11 command line parser"
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://unicode.org.license.html;beginline=42;endline=85;md5=67619d0c52706853c0256514e7fd04cd"
+
+SRC_URI = " \
+ https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd \
+ https://www.unicode.org/license.html;name=license;subdir=${BP};downloadfilename=unicode.org.license.html \
+"
+SRC_URI[ucd.md5sum] = "430cbdac2615451571dd69a976dd08f6"
+SRC_URI[ucd.sha256sum] = "25ba51a0d4c6fa41047b7a5e5733068d4a734588f055f61e85f450097834a0a6"
+
+SRC_URI[license.md5sum] = "f03bafb623258f85ff2032c1ce567b7c"
+SRC_URI[license.sha256sum] = "983225207de8a707d0903a8d70fb7a4b28c5e0f64f2366e84a6192a2d618fed4"
+
+inherit allarch
+
+do_configure[noexec] = "1"
+
+do_install() {
+ install -d ${D}${datadir}/unicode
+ cp -rf ${WORKDIR}/ucd ${D}${datadir}/unicode
+}
+
+FILES_${PN} = "${datadir}/unicode/ucd"