aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-07 16:33:40 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-09 10:17:15 -0800
commit964ae9f79841fdd56266c3598cc72b9f0f45c2e4 (patch)
tree9c54aab450335a8e8c966621e0f75b73d9bbac58 /meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb
parent5c5befa94d5bf52716cb08098e6c5beadd5a86fa (diff)
downloadmeta-openembedded-contrib-964ae9f79841fdd56266c3598cc72b9f0f45c2e4.tar.gz
uhubctl: upgrade 2.4.0 -> 2.5.0
Changelog: =========== * Added support for Linux sysfs based power switching provided in Linux kernel 6.0+ - it allows to solve reliability issues when turning power off on Linux (#450). * Added option --nodesc to skip querying device string descriptors (necessary for some buggy devices which otherwise would completely freeze). * New simpler way to configure udev rules on Linux (one rule works for any USB hub). * Even more supported devices. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb')
-rw-r--r--meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb b/meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb
new file mode 100644
index 0000000000..8b334dbdec
--- /dev/null
+++ b/meta-oe/recipes-support/uhubctl/uhubctl_2.5.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "USB hub per-port power control"
+HOMEPAGE = "https://github.com/mvp/uhubctl"
+BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
+DEPENDS = "libusb1"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCREV = "20276ad5ced147d018e2b3fccedabd94597aa25e"
+SRC_URI = "git://github.com/mvp/${BPN};branch=master;protocol=https"
+S = "${WORKDIR}/git"
+
+# uhubctl gets its program version from "git describe". As we use the source
+# archive do reduce download size replace the call with our hardcoded version.
+do_configure:append() {
+ sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}