aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tree/tree_2.0.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-02-23 15:52:47 +0800
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:35:24 -0800
commit6f2008ee408d89fdcea22a63e72cd40ff02db3e3 (patch)
tree00bbdacd6dfd7012a6c6f24fb177396c8423199f /meta-oe/recipes-support/tree/tree_2.0.2.bb
parentebc0de88535f8fa2d8f6fab3ccedde02108ff81d (diff)
downloadmeta-openembedded-contrib-6f2008ee408d89fdcea22a63e72cd40ff02db3e3.tar.gz
tree: upgrade 2.0.1 -> 2.0.2
Changelog: ========= - Okay, apparently the stddata addition is causing havoc (who knew how many scripts just haphazardly hand programs random file descriptors, that's surely not a problem.) Going forward the stddata option will only work if the environment variable STDDATA_FD is present or set to the descriptor to produce the JSON output on. - Fix HTML url output issue. It was definitely broken in the 2.0.0 release, and this should normalize it with respect to older versions. - Update MANPATH for OS X - Fixed an error with * in the patchmatch code where *foo*bar would match *foo alone. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tree/tree_2.0.2.bb')
-rw-r--r--meta-oe/recipes-support/tree/tree_2.0.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tree/tree_2.0.2.bb b/meta-oe/recipes-support/tree/tree_2.0.2.bb
new file mode 100644
index 0000000000..ec68db2456
--- /dev/null
+++ b/meta-oe/recipes-support/tree/tree_2.0.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A recursive directory listing command"
+HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
+SRC_URI[sha256sum] = "7d693a1d88d3c4e70a73e03b8dbbdc12c2945d482647494f2f5bd83a479eeeaf"
+
+# tree's default CFLAGS for Linux
+CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_configure[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/
+}