aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tbb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-13 00:22:03 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-15 09:28:43 -0700
commit2a88ae98e9fd394cdc9f332a69eafa5b2cab5b33 (patch)
tree8dd70f1bad97d49c93d2804e8edaf76b3fe7cf66 /meta-oe/recipes-support/tbb
parent644b75926b0d2c707dc6406bbfa40c436b84c4ff (diff)
downloadmeta-openembedded-contrib-2a88ae98e9fd394cdc9f332a69eafa5b2cab5b33.tar.gz
tbb: Fix build with musl
Need to link libucontext on musl Additionally, mips also needs libatomic Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Naveen Saini <naveen.kumar.saini@intel.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r--meta-oe/recipes-support/tbb/tbb_2021.2.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb b/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
index d0e2311402..b05a59dc70 100644
--- a/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
+++ b/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
@@ -6,6 +6,9 @@ DESCRIPTION = "Parallelism library for C++ - runtime files \
HOMEPAGE = "https://software.intel.com/en-us/tbb"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS_append_libc-musl = " libucontext"
+
BRANCH = "onetbb_2021"
SRCREV = "2dba2072869a189b9fdab3ffa431d3ea49059a19"
SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
@@ -33,3 +36,10 @@ EXTRA_OECMAKE += " \
# ...
# | make[1]: *** [concurrent_queue.o] Error 1
ARM_INSTRUCTION_SET = "arm"
+
+ASNEEDED = ""
+
+LDFLAGS_append_mips = " -latomic"
+LDFLAGS_append_mipsel = " -latomic"
+
+LDFLAGS_append_libc-musl = " -lucontext"