aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/talloc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-21 11:09:58 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 13:06:14 +0200
commit12cdf070d210f4a66ad2851d933a432d66d1f2b3 (patch)
tree1ed69e62ca575a035294a460188634602c76c130 /meta-oe/recipes-support/talloc
parent01eb0f919275c36db2ac6066a1158c17cce8ba95 (diff)
downloadmeta-openembedded-contrib-12cdf070d210f4a66ad2851d933a432d66d1f2b3.tar.gz
talloc: fix build with B!=S
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/talloc')
-rw-r--r--meta-oe/recipes-support/talloc/talloc/sepbuild.patch27
-rw-r--r--meta-oe/recipes-support/talloc/talloc_2.0.1.bb7
2 files changed, 29 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc/sepbuild.patch b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
new file mode 100644
index 0000000000..05506c3423
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
@@ -0,0 +1,27 @@
+Index: talloc-2.0.1/Makefile.in
+===================================================================
+--- talloc-2.0.1.orig/Makefile.in
++++ talloc-2.0.1/Makefile.in
+@@ -33,8 +33,8 @@ EXPORTSFILE = @EXPORTSFILE@
+
+ all:: showflags $(EXTRA_TARGETS)
+
+-include $(tallocdir)/rules.mk
+-include $(tallocdir)/talloc.mk
++include $(srcdir)/$(tallocdir)/rules.mk
++include $(srcdir)/$(tallocdir)/talloc.mk
+
+ @TALLOC_COMPAT1_MK@
+
+Index: talloc-2.0.1/libtalloc.m4
+===================================================================
+--- talloc-2.0.1.orig/libtalloc.m4
++++ talloc-2.0.1/libtalloc.m4
+@@ -33,6 +33,6 @@ if test $ac_cv_sizeof_size_t -lt $ac_cv_
+ fi
+
+ if test x"$VERSIONSCRIPT" != "x"; then
+- EXPORTSFILE=talloc.exports
++ EXPORTSFILE=$srcdir/$tallocdir/talloc.exports
+ AC_SUBST(EXPORTSFILE)
+ fi
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
index 6b7e4f1cfd..62bda71e69 100644
--- a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
+++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
@@ -7,6 +7,7 @@ inherit autotools pkgconfig
SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \
file://install-swig-interface-in-SWINGLIBDIR.patch \
+ file://sepbuild.patch \
"
SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b"
SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4"
@@ -15,11 +16,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
PR = "r2"
-# autoreconf doesn't work well while reconfiguring included libreplace
-do_configure () {
- gnu-configize
- oe_runconf
-}
+EXTRA_AUTORECONF = "--exclude=autopoint --exclude=aclocal"
do_install_prepend() {
# Hack the way swig interface for talloc is installed