aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/system-config-keyboard
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-03-10 12:16:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:39 +0100
commit504fc47cec26704bf4a02dba5e6a0dccb46e9b39 (patch)
treedda603c0b28ed029e64fe8964df1677f8d0ff155 /meta-oe/recipes-support/system-config-keyboard
parent7ebeb6ba4bca44cd304b73aa596de78fd977ab85 (diff)
downloadmeta-openembedded-contrib-504fc47cec26704bf4a02dba5e6a0dccb46e9b39.tar.gz
system-config-keyboard: inherit gettext and add dependency on intltool-native
* it actually depends on native intltool: NOTE: recipe system-config-keyboard-1.4.0-r0: task do_compile: Started ERROR: system-config-keyboard-1.4.0-r0 do_compile: oe_runmake failed ERROR: system-config-keyboard-1.4.0-r0 do_compile: Function failed: do_compile (log file is located at /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/system-config-keyboard/1.4.0-r0/temp/log.do_compile.16052) ERROR: Logfile of failure stored in: /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/system-config-keyboard/1.4.0-r0/temp/log.do_compile.16052 Log data follows: | DEBUG: Executing shell function do_compile | NOTE: make -j 8 PYTHON=/home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/bin/python-native/python PYTHON_SITELIB=/usr/lib/python2.7/site-packages | make: intltool-merge: Command not found | make: *** [system-config-keyboard.desktop] Error 127 | ERROR: oe_runmake failed | ERROR: Function failed: do_compile (log file is located at /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/system-config-keyboard/1.4.0-r0/temp/log.do_compile.16052) NOTE: recipe system-config-keyboard-1.4.0-r0: task do_compile: Failed * and it also used gettext: | DEBUG: Executing shell function do_compile | NOTE: make -j 8 PYTHON=/home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/bin/python-native/python PYTHON_SITELIB=/usr/lib/python2.7/site-packages | cd po && for i in *.po; do msgfmt $i -o $(echo $i |sed s/.po/.mo/) || exit 1; done | echo -e "#!/bin/sh\nexec /usr/bin/pkexec /usr/sbin/system-config-keyboard \"\$@\"" > "system-config-keyboard.sh" | chmod 755 "system-config-keyboard.sh" | /bin/sh: 1: msgfmt: not found | make: *** [gettext] Error 1 | make: *** Waiting for unfinished jobs.... | Merging translations into system-config-keyboard.desktop. | WARNING: exit code 1 from a shell command. | ERROR: oe_runmake failed | ERROR: Function failed: do_compile (log file is located at /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/system-config-keyboard/1.4.0-r0/temp/log.do_compile.23230) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/system-config-keyboard')
-rw-r--r--meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
index eaca96dcaa..078fcea5be 100644
--- a/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
+++ b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
@@ -6,7 +6,9 @@ SRC_URI = "https://fedorahosted.org/releases/s/y/${BPN}/${BP}.tar.bz2"
SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72"
SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284"
inherit python-dir
-DEPENDS = "intltool"
+
+inherit python-dir gettext
+DEPENDS = "intltool-native"
EXTRA_OEMAKE = " \
PYTHON='${STAGING_BINDIR_NATIVE}'/python-native/python \