aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-08-12 14:26:13 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-13 23:28:05 +0200
commitc0ce7599526c4dce6d889fc4a5aa007f445e6d76 (patch)
tree6dd1e4b095cf937f2a50466daf4a2a1a6796fb9a /meta-oe/recipes-support/syslog-ng/syslog-ng.inc
parentefea141c6e6e44ca48f3837e5c3383ccfe9ba247 (diff)
downloadmeta-openembedded-contrib-c0ce7599526c4dce6d889fc4a5aa007f445e6d76.tar.gz
syslog-ng: fix do_compi1e of qemuarm while DEBUG_BUILD
The thread local storage caused arm-gcc broken while compiling syslog-ng with option '-g -O'. ... dnscache.s: Assembler messages: dnscache.s:100: Error: invalid operands (.text and *UND* sections) for `-' ... Add option --enable-thread-tls in configure to explicitly disable thread local storage for arm while DEBUG_BUILD enabled. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/syslog-ng/syslog-ng.inc')
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 57976b3a2a..22767778f6 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -18,6 +18,7 @@ SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source
file://syslog-ng.conf \
file://initscript \
file://volatiles.03_syslog-ng \
+ file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
"
inherit autotools systemd pkgconfig update-rc.d update-alternatives
@@ -32,8 +33,12 @@ EXTRA_OECONF = " \
--with-sysroot=${STAGING_DIR_HOST} \
--with-libmongo-client=no --disable-mongodb \
--with-librabbitmq-client=no \
+ ${CONFIG_TLS} \
"
+CONFIG_TLS = "--enable-thread-tls"
+CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
+
PACKAGECONFIG ??= "openssl \
${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \