aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/start-stop-daemon
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-08-16 15:06:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:01 +0200
commit8023c643932b61a95bb14226dd2f5668f9cafed2 (patch)
tree75e1fb49302854585fd77fdde6c8ac66984149fd /meta-oe/recipes-support/start-stop-daemon
parentd5e04a6b287d1a2140cc0b9f1a9a6a54b18491b9 (diff)
downloadmeta-openembedded-contrib-8023c643932b61a95bb14226dd2f5668f9cafed2.tar.gz
start-stop-daemon: Only create a link in ${base_sbindir} if necessary
If usrmerge is enabled in DISTRO_FEATURES, then ${base_sbindir} and ${sbindir} are set to the same path and the symbolic link from ${base_sbindir}/start-stop-daemon to ${sbindir}/start-stop-daemon can (and should) not be created. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/start-stop-daemon')
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
index 5ee4472cd9..cc2727b758 100644
--- a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
@@ -31,6 +31,8 @@ do_install_append () {
# support for buggy init.d scripts that refer to an alternative
# explicit path to start-stop-daemon
- mkdir -p ${D}/sbin/
- ln -sf /usr/sbin/start-stop-daemon ${D}/sbin/start-stop-daemon
+ if [ "${base_sbindir}" != "${sbindir}" ]; then
+ mkdir -p ${D}${base_sbindir}
+ ln -sf ${sbindir}/start-stop-daemon ${D}${base_sbindir}/start-stop-daemon
+ fi
}