aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ssiapi
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-05-23 15:01:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:45 +0200
commit332b5ce49b7be2a6883828e83fb9ab129eb67ba2 (patch)
treea3a75a7e7b2b0babf1dcf1e3187bc6e2412d01f3 /meta-oe/recipes-support/ssiapi
parent29e111093bc97806ea5e96d1526fa93b055fac18 (diff)
downloadmeta-openembedded-contrib-332b5ce49b7be2a6883828e83fb9ab129eb67ba2.tar.gz
ssiapi: add new recipe
Intel Rapid Storage Technology enterprise with Linux OS* Standard Storage Interface API Library. The library allows user to manage storage devices including creating and managing Raid arrays on systems with Intel chipset. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/ssiapi')
-rw-r--r--meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb b/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb
new file mode 100644
index 0000000000..5b951eb266
--- /dev/null
+++ b/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Intel RSTe with Linux OS SSI API Library"
+
+DESCRIPTION = "Intel Rapid Storage Technology enterprise with Linux OS* Standard Storage Interface API Library. \
+The library allows user to manage storage devices including creating and managing Raid arrays on systems with Intel chipset."
+
+HOMEPAGE = "http://irstessi.sourceforge.net/"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0413ff365e0bd733c4869a6797551c6f"
+
+DEPENDS += "sg3-utils"
+
+SRC_URI = "http://sourceforge.net/projects/irstessi/files/${BPN}.${PV}.tgz"
+SRC_URI[md5sum] = "02f16d7cbd30d28034093212906591f5"
+SRC_URI[sha256sum] = "e10d283b0f211afb8ebd0bde87c097769613d30a052cdf164753e35e803264c7"
+
+S ="${WORKDIR}/${BPN}.${PV}"
+
+inherit autotools-brokensep
+
+do_configure_prepend(){
+ ./autogen.sh
+}
+
+RDEPENDS_${PN} += "mdadm"