aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/satyr/satyr_0.39.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-12-20 23:02:21 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-21 18:49:37 -0800
commit917d6c301a8e648e9037dcdd72b3b93806cb9282 (patch)
treeddabab3b1d30fb65eea9954a40a0de45a85e2062 /meta-oe/recipes-support/satyr/satyr_0.39.bb
parentc581dc38d7bd1481a4251b99e0984fe05f53569a (diff)
downloadmeta-openembedded-contrib-917d6c301a8e648e9037dcdd72b3b93806cb9282.tar.gz
satyr: upgrade 0.38 -> 0.39
Changelog: ========= Use g_malloc() and g_free() instead of malloc()/free() in many instances Fix call to a deprecated in Python tests Add test case for sr_rpm_package_cmp() Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/satyr/satyr_0.39.bb')
-rw-r--r--meta-oe/recipes-support/satyr/satyr_0.39.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/satyr/satyr_0.39.bb b/meta-oe/recipes-support/satyr/satyr_0.39.bb
new file mode 100644
index 0000000000..732a1440e0
--- /dev/null
+++ b/meta-oe/recipes-support/satyr/satyr_0.39.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
+failure processing, analysis, and reporting supporting kernel space, user \
+space, Python, and Java programs"
+
+HOMEPAGE = "https://github.com/abrt/satyr"
+LICENSE = "GPLv2"
+
+inherit autotools-brokensep python3native pkgconfig
+
+SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \
+ file://0002-fix-compile-failure-against-musl-C-library.patch \
+"
+SRCREV = "f8a0dbfe7fcc6e44f03d66ca5c81363aea318380"
+S = "${WORKDIR}/git"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS += " \
+ gdb \
+ gperf-native \
+ json-c \
+ nettle \
+ glib-2.0 \
+"
+
+PACKAGES += "python3-${BPN}"
+FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+
+PACKAGECONFIG ??= "python3 rpm"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
+
+do_configure:prepend() {
+ ${S}/gen-version
+}