aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/satyr/satyr_0.28.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-09-02 17:41:31 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-02 12:52:46 -0700
commitfc5139e391610ffd2f9977bd696fed111ce801e5 (patch)
treeb6c4f7229f02e134a9469d0bf6b271ff09abf91a /meta-oe/recipes-support/satyr/satyr_0.28.bb
parenteb2b608cf947c0f67959a50c483f311562dcf63c (diff)
downloadmeta-openembedded-contrib-fc5139e391610ffd2f9977bd696fed111ce801e5.tar.gz
satyr: upgrade 0.27 -> 0.28
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/satyr/satyr_0.28.bb')
-rw-r--r--meta-oe/recipes-support/satyr/satyr_0.28.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/satyr/satyr_0.28.bb b/meta-oe/recipes-support/satyr/satyr_0.28.bb
new file mode 100644
index 0000000000..fbf018d7f5
--- /dev/null
+++ b/meta-oe/recipes-support/satyr/satyr_0.28.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
+failure processing, analysis, and reporting supporting kernel space, user \
+space, Python, and Java programs"
+
+HOMEPAGE = "https://github.com/abrt/satyr"
+LICENSE = "GPLv2"
+
+inherit autotools-brokensep python3native pkgconfig
+
+SRC_URI = "git://github.com/abrt/satyr.git \
+ file://0002-fix-compile-failure-against-musl-C-library.patch \
+"
+SRCREV = "8b5547b89b712b39a59f1d8b366e7de0f5f46108"
+S = "${WORKDIR}/git"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS += " \
+ gdb \
+"
+
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+
+PACKAGECONFIG ??= "python3 rpm"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
+
+do_configure_prepend() {
+ ${S}/gen-version
+}