aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-10-17 02:49:30 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-27 12:50:00 +0100
commit0ee5bea84105040ae54bcbc5d2baac7be80bc801 (patch)
tree8294c2c9f214351c7636d46ded2187919ce125fb /meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
parent39357871df157f2cb0013599758143fb006cfe9d (diff)
downloadmeta-openembedded-contrib-0ee5bea84105040ae54bcbc5d2baac7be80bc801.tar.gz
rsnapshot: fix rsnapshot.conf.default
This change is used for fixing cmd path in rsnapshot.conf.default. The options --without-* disable checking command * on host and get the default path used, otherwise the host path will be injected into target configs. The runtime dependencies to ssh, logger, cp, du are optional and could be customized in rsnapshot.conf, so it's not needed that using PACKAGECONFIG to define the runtime dependencies. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb')
-rw-r--r--meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb b/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
index afd3678060..3f919b568f 100644
--- a/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
+++ b/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
@@ -24,11 +24,19 @@ SRCREV = "1047cbb57937c29233388e2fcd847fecd3babe74"
PV = "1.3.1+git${SRCPV}"
SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=git \
+ file://configure-fix-cmd_rsync.patch \
"
S = "${WORKDIR}/git"
inherit autotools
-PACKAGECONFIG ??= "logger"
-PACKAGECONFIG[logger] = "--with-logger=${bindir}/logger,--without-logger,,util-linux"
+# Fix rsnapshot.conf.default:
+# don't inject the host path into target configs.
+EXTRA_OECONF += "--without-cp \
+ --without-rm \
+ --without-du \
+ --without-ssh \
+ --without-logger \
+ --without-rsync \
+ "