aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/remmina/remmina_1.4.11.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez Samaniego <alejandro@enedino.org>2021-02-28 16:21:13 -0700
committerKhem Raj <raj.khem@gmail.com>2021-02-28 23:51:14 -0800
commit34e64820ec65f36f513c7fc6805339667265c792 (patch)
tree9dff9491e8e3a47de36abb6e6d6722817c2b049a /meta-oe/recipes-support/remmina/remmina_1.4.11.bb
parentc6a5fa624c4c196782f6a6acc1f4426df3dce781 (diff)
downloadmeta-openembedded-contrib-34e64820ec65f36f513c7fc6805339667265c792.tar.gz
remmina: Upgrade 1.4.10 -> 1.4.11
Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/remmina/remmina_1.4.11.bb')
-rw-r--r--meta-oe/recipes-support/remmina/remmina_1.4.11.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/remmina/remmina_1.4.11.bb b/meta-oe/recipes-support/remmina/remmina_1.4.11.bb
new file mode 100644
index 0000000000..215c04a228
--- /dev/null
+++ b/meta-oe/recipes-support/remmina/remmina_1.4.11.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+"
+HOMEPAGE = "https://remmina.org"
+SECTION = "Support"
+LICENSE = "GPLv2 & openssl"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
+DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi libsodium libssh vte json-glib libsoup-2.4 libvncserver libsecret libxkbfile"
+
+
+DEPENDS_append_libc-musl = " libexecinfo"
+LDFLAGS_append_libc-musl = " -lexecinfo"
+
+SRCREV = "6a8737111adebf571c46f35599cc62e7f7b0bd65"
+SRC_URI = "git://gitlab.com/Remmina/Remmina;protocol=https;branch=rel/v1.4.11 \
+"
+
+PV .= "+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake features_check mime-xdg
+REQUIRED_DISTRO_FEATURES = "x11"
+
+EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF"
+
+do_install_append(){
+ # We dont need the extra stuff form other desktop environments
+ rm -rf ${D}/${datadir}/xsessions
+ rm -rf ${D}/${datadir}/metainfo
+ rm -rf ${D}/${datadir}/gnome-session
+}
+
+PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol"
+
+RDEPENDS_${PN} = "bash"
+
+FILES_${PN}_append = " ${datadir}/icons/hicolor/*"