aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/portaudio
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-26 18:23:27 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-27 08:54:40 -0700
commit769d79278403a193bdc4fbb68c9e21aab6cb71d1 (patch)
tree19a04c84b5b4a0d3f23f582d12e6a31e247baeab /meta-oe/recipes-support/portaudio
parent8af2f17a6fa8bf282c4c27054adbea1bf0873069 (diff)
downloadmeta-openembedded-contrib-769d79278403a193bdc4fbb68c9e21aab6cb71d1.tar.gz
portaudio-v19: Update to latest tip of trunk
The patches are already upstreamed therefore deleted. Additionally it fixes shared library versioning scheme which in turn fixes build of dependent package python3-pyaudio failing with QA Issue: /usr/lib/python3.11/site-packages/pyaudio/_portaudio.cpython-311-x86_64-linux-gnu.so contained in package python3-pyaudio requires libportaudio.so.2()(64bit), but no providers found in RDEPENDS:python3-pyaudio? [file-rdeps] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/portaudio')
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch32
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch49
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb16
3 files changed, 6 insertions, 91 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch
deleted file mode 100644
index d6c6300ecd..0000000000
--- a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 8ec1b100afda5b3e31f9d44af04b04b16dfff2e4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Tue, 18 May 2021 00:15:46 +0200
-Subject: [PATCH] Find jack with pkgconfig
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Pending
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 122fe93..ab7d7f5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -274,7 +274,8 @@ ELSE()
-
- ELSEIF(UNIX)
-
-- FIND_PACKAGE(Jack)
-+ find_package(PkgConfig REQUIRED)
-+ pkg_check_modules (JACK jack)
- IF(JACK_FOUND)
- OPTION(PA_USE_JACK "Enable support for Jack" ON)
- ELSE()
---
-2.31.1
-
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
deleted file mode 100644
index 892399de70..0000000000
--- a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From ced7af0420c1df0ac02f0c25e7c3534431ebd7fd Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 4 Jul 2021 17:09:49 -0700
-Subject: [PATCH] cmake: Use GNUInstallDirs
-
-Helps install cmakefiles in right libdir
-
-Upstream-Status: Submitted [https://github.com/PortAudio/portaudio/pull/610]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,6 +6,8 @@
-
- CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
-
-+include(GNUInstallDirs)
-+
- # Check if the user is building PortAudio stand-alone or as part of a larger
- # project. If this is part of a larger project (i.e. the CMakeLists.txt has
- # been imported by some other CMakeLists.txt), we don't want to trump over
-@@ -452,18 +454,18 @@ IF(NOT PA_OUTPUT_OSX_FRAMEWORK AND NOT P
- CONFIGURE_FILE(cmake_support/portaudio-2.0.pc.in ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc @ONLY)
- INSTALL(FILES README.md DESTINATION share/doc/portaudio)
- INSTALL(FILES LICENSE.txt DESTINATION share/doc/portaudio)
-- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION lib/pkgconfig)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
- INSTALL(FILES ${PA_PUBLIC_INCLUDES} DESTINATION include)
- INSTALL(TARGETS ${PA_TARGETS}
- EXPORT portaudio-targets
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-- INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "lib/cmake/portaudio")
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
- EXPORT(TARGETS ${PA_TARGETS} FILE "${PROJECT_BINARY_DIR}/cmake/portaudio/portaudioTargets.cmake")
- INSTALL(FILES "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfig.cmake"
- "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfigVersion.cmake"
-- DESTINATION "lib/cmake/portaudio")
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
-
- IF (NOT TARGET uninstall)
- CONFIGURE_FILE(
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
index f34912ed28..c49a2599ac 100644
--- a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
@@ -3,18 +3,17 @@ SECTION = "libs/multimedia"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
-PV = "v190700"
+PV .= "+git${SRCPV}"
+
+SRC_URI = "git://github.com/PortAudio/portaudio.git;branch=master;protocol=https"
+SRCREV = "929e2e8f7af281c5eb4fa07758930d542ec43d97"
-SRC_URI = " \
- git://github.com/PortAudio/portaudio.git;branch=master;protocol=https \
- file://0001-Find-jack.patch \
- file://0001-cmake-Use-GNUInstallDirs.patch \
-"
-SRCREV = "147dd722548358763a8b649b3e4b41dfffbcfbb6"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
+
PACKAGECONFIG ??= "alsa jack"
PACKAGECONFIG[alsa] = ",,alsa-lib"
PACKAGECONFIG[jack] = ",,jack"
@@ -28,6 +27,3 @@ do_install:append() {
done
fi
}
-
-FILES_SOLIBSDEV = ""
-FILES:${PN} += "${libdir}/libportaudio.so"