aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-11-06 23:06:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:38:22 +0100
commit06a1221a310364550e3662b16c2a3c5a2ca297a2 (patch)
treef68c7fac489680c12bda6858cda190b1ca4d9c7c /meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb
parent14768271aa4f8e50245617b6181da3a1a732cc9e (diff)
downloadmeta-openembedded-contrib-06a1221a310364550e3662b16c2a3c5a2ca297a2.tar.gz
portaudio-v19: update to v190600 released on 20161030
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb')
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb b/meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb
new file mode 100644
index 0000000000..489f8ad9e2
--- /dev/null
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19_20161030.bb
@@ -0,0 +1,32 @@
+SUMMARY = "A portable audio library"
+SECTION = "libs/multimedia"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
+
+PV = "v190600"
+
+SRC_URI = "http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz \
+ file://ldflags.patch"
+SRC_URI[md5sum] = "4df8224e047529ca9ad42f0521bf81a8"
+SRC_URI[sha256sum] = "f5a21d7dcd6ee84397446fa1fa1a0675bb2e8a4a6dceb4305a8404698d8d1513"
+
+S = "${WORKDIR}/portaudio"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "alsa jack"
+PACKAGECONFIG[alsa] = "--with-alsa, --without-alsa, alsa-lib,"
+PACKAGECONFIG[jack] = "--with-jack, --without-jack, jack,"
+
+EXTRA_OECONF = "--without-oss --without-asihpi"
+
+do_install_append() {
+ mkdir --parents ${D}${bindir}
+ for b in ${B}/bin/pa*; do
+ # Bit nasty, should always work
+ ${B}/*-libtool --mode install install $b ${D}${bindir}
+ done
+}
+
+PACKAGES += "portaudio-examples"
+FILES_portaudio-examples = "${bindir}"