aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-04-20 11:12:16 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-21 07:14:38 -0700
commit5fa0188b8c754e410583fc329f62a30f9cb82831 (patch)
tree7041495b7762d4ea4c1b89843fd393a63819a4f8 /meta-oe/recipes-support/poppler
parentfa5922c1cb664cdd6baff75831626ed3285026d7 (diff)
downloadmeta-openembedded-contrib-5fa0188b8c754e410583fc329f62a30f9cb82831.tar.gz
poppler: Support building for native
* Disable RUN_GPERF_IF_PRESENT. Otherwise cmake will look for gperf. For target, it will not find it and proceeds to use the pregenerated files. However, for native it finds `/usr/bin/gperf`, but then tries to run `gperf` instead, which fails since it is not in hosttools. * Disable ENABLE_CPP for native. Otherwise it needs iconv, which it cannot find. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r--meta-oe/recipes-support/poppler/poppler_22.04.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_22.04.0.bb b/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
index 9c9122160c..b7cdb4f1be 100644
--- a/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
@@ -33,9 +33,11 @@ EXTRA_OECMAKE += " \
-DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
-DBUILD_GTK_TESTS=OFF \
-DENABLE_ZLIB=ON \
+ -DRUN_GPERF_IF_PRESENT=OFF \
-DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
"
+EXTRA_OECMAKE:append:class-native = " -DENABLE_CPP=OFF"
do_configure:append() {
# poppler macro uses pkg-config to check for g-ir runtimes. Something
@@ -49,3 +51,5 @@ FILES:libpoppler = "${libdir}/libpoppler.so.*"
FILES:libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
RDEPENDS:libpoppler = "poppler-data"
+
+BBCLASSEXTEND = "native"