aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-03-22 11:21:26 +0100
committerKhem Raj <raj.khem@gmail.com>2019-03-22 09:33:00 -0700
commit735c2b38034df0fb839c253d2e0ae264ab693702 (patch)
tree6d550318e8d534af138b7d3cf73836584a0c5eef /meta-oe/recipes-support/poppler
parent2c417a5680537c31c3a3a9fd355b2c3cf90285cb (diff)
downloadmeta-openembedded-contrib-735c2b38034df0fb839c253d2e0ae264ab693702.tar.gz
poppler: upgrade 0.71.0 -> 0.75.0
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch9
-rw-r--r--meta-oe/recipes-support/poppler/poppler/basename-include.patch2
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.75.0.bb (renamed from meta-oe/recipes-support/poppler/poppler_0.71.0.bb)6
3 files changed, 10 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
index 7ed795ef7b..c364d7372c 100644
--- a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
+++ b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
@@ -15,15 +15,18 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
-index 33c6608..87e1b44 100644
+index 6f91669..ca5021f 100644
--- a/glib/CMakeLists.txt
+++ b/glib/CMakeLists.txt
-@@ -127,7 +127,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_LIBS)
+@@ -135,7 +135,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_LIBS)
get_directory_property(_tmp_includes INCLUDE_DIRECTORIES)
_list_prefix(_includes _tmp_includes "-I")
- set(Poppler_0_18_gir_CFLAGS ${_includes} -L${CMAKE_BINARY_DIR})
+ set(Poppler_0_18_gir_CFLAGS ${_includes} -L${CMAKE_BINARY_DIR} -L${CMAKE_CURRENT_BINARY_DIR})
- set(Poppler_0_18_gir_LIBS poppler-glib)
+ set(Poppler_0_18_gir_LIBS poppler-glib poppler)
_list_prefix(_abs_introspection_files introspection_files "${CMAKE_CURRENT_SOURCE_DIR}/")
list(APPEND _abs_introspection_files
${CMAKE_CURRENT_BINARY_DIR}/poppler-enums.c
+--
+2.20.1
+
diff --git a/meta-oe/recipes-support/poppler/poppler/basename-include.patch b/meta-oe/recipes-support/poppler/poppler/basename-include.patch
index 528528ae7c..ab6bdb0806 100644
--- a/meta-oe/recipes-support/poppler/poppler/basename-include.patch
+++ b/meta-oe/recipes-support/poppler/poppler/basename-include.patch
@@ -8,8 +8,8 @@ Index: poppler-0.64.0/utils/pdfsig.cc
--- poppler-0.64.0.orig/utils/pdfsig.cc
+++ poppler-0.64.0/utils/pdfsig.cc
@@ -35,6 +35,10 @@
- #include "Win32Console.h"
#include "numberofcharacters.h"
+ #include <libgen.h>
+#if !defined(__GLIBC__)
+#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src)
diff --git a/meta-oe/recipes-support/poppler/poppler_0.71.0.bb b/meta-oe/recipes-support/poppler/poppler_0.75.0.bb
index 371648d1ae..febdc8edac 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.71.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.75.0.bb
@@ -8,8 +8,8 @@ SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
file://0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch \
file://basename-include.patch \
"
-SRC_URI[md5sum] = "b505011e49e922c83f3ffb57ab40bc28"
-SRC_URI[sha256sum] = "badbecd2dddf63352fd85ec08a9c2ed122fdadacf2a34fcb4cc227c4d01f2cf9"
+SRC_URI[md5sum] = "3fb4ca803d989742695ca586c5cc489e"
+SRC_URI[sha256sum] = "3bbaedb0fa2797cac933a0659d144303e4d09eec6892c65600da987d8707199a"
DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
@@ -40,7 +40,7 @@ EXTRA_OECMAKE += " \
do_configure_append() {
# poppler macro uses pkg-config to check for g-ir runtimes. Something
# makes them point to /usr/bin. Align them to sysroot - that's where the
- # git-wrappers are:
+ # gir-wrappers are:
sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
}