aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler/poppler_22.02.0.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@fujitsu.com>2022-02-23 10:35:53 +0800
committerKhem Raj <raj.khem@gmail.com>2022-02-23 09:25:19 -0800
commit44a810f34e20c7985b0bcbdf71943799b278ecc7 (patch)
treebc4b3ec097374b13cda6d62d6cd447390989b405 /meta-oe/recipes-support/poppler/poppler_22.02.0.bb
parente40eb83ded047363443eeb1b8adb67c6100f75c4 (diff)
downloadmeta-openembedded-contrib-44a810f34e20c7985b0bcbdf71943799b278ecc7.tar.gz
poppler: upgrade 22.01.0 -> 22.02.0
Changelog: ========= core: * Signature: Add a way to detect unsigned FormFieldSignature * Signature: Suport background image when using left and right text * Signature: Fix path where to search for Firefox NSS in Windows * Signature: Fix NSS code to work correctly in Windows/Android * Count only signature fields in PDFDoc::getNumSignatureFields * Minor code improvements qt: * Allow signing unsigned signature fields * Allow passing a background image for the signature when signing * Allow passing the document password when signing * Fix leftFontSize being ignored when signing glib: * try with utf8 password if latin1 fails * New method for getting all signature fields of a document * Fix compile with MSVC utils: * pdfsig: Fix compile with MSVC build system: * Fix NSS cmake check for MSVC Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler_22.02.0.bb')
-rw-r--r--meta-oe/recipes-support/poppler/poppler_22.02.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_22.02.0.bb b/meta-oe/recipes-support/poppler/poppler_22.02.0.bb
new file mode 100644
index 0000000000..2954a89b8e
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler_22.02.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE = "https://poppler.freedesktop.org/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
+ file://0001-Do-not-overwrite-all-our-build-flags.patch \
+ file://basename-include.patch \
+ "
+SRC_URI[sha256sum] = "e390c8b806f6c9f0e35c8462033e0a738bb2460ebd660bdb8b6dca01556193e1"
+
+DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
+
+inherit cmake pkgconfig gobject-introspection
+
+PACKAGECONFIG ??= "jpeg openjpeg png tiff nss splash"
+PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
+PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
+PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
+PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
+PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
+PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
+PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
+PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON -DENABLE_BOOST=ON,-DENABLE_SPLASH=OFF -DENABLE_BOOST=OFF,boost"
+
+# surprise - did not expect this to work :)
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
+
+SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
+
+EXTRA_OECMAKE += " \
+ -DENABLE_CMS=lcms2 \
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
+ -DBUILD_GTK_TESTS=OFF \
+ -DENABLE_ZLIB=ON \
+ -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
+ ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
+"
+
+do_configure:append() {
+ # poppler macro uses pkg-config to check for g-ir runtimes. Something
+ # makes them point to /usr/bin. Align them to sysroot - that's where the
+ # gir-wrappers are:
+ sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
+}
+
+PACKAGES =+ "libpoppler libpoppler-glib"
+FILES:libpoppler = "${libdir}/libpoppler.so.*"
+FILES:libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
+
+RDEPENDS:libpoppler = "poppler-data"