aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-05 13:31:17 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 11:00:52 +0200
commit2ba483aecc7e4430c9dd6491faf8881427332f43 (patch)
tree3dd7d3537764bb01b19065b82a3175be5c367a8f /meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
parent47604c0409caedabc47f7bc7fe5be5c112b80c9c (diff)
downloadmeta-openembedded-contrib-2ba483aecc7e4430c9dd6491faf8881427332f43.tar.gz
pngcheck: Fix cross build and format string errors
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb')
-rw-r--r--meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
index 6d0dfff930..9f617ecda5 100644
--- a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
+++ b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
@@ -4,15 +4,21 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://gpl/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "zlib libpng"
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/png-mng/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/png-mng/${BPN}/${PV}/${BPN}-${PV}.tar.gz \
+ file://10-pngsplit-format-strings.patch \
+ file://0001-png-fix-IDAT-windowsize-Fix-format-string-errors-in-.patch \
+ file://0001-make-Respect-variables-from-environement.patch \
+ "
SRC_URI[md5sum] = "980bd6d9a3830fdce746d7fe3c9166ee"
SRC_URI[sha256sum] = "77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db25690f35f"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+CFLAGS += "-DUSE_ZLIB"
+
+EXTRA_OEMAKE = "-f ${S}/Makefile.unx"
do_compile() {
- oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS='${STAGING_DIR_HOST}${libdir}/libz.a ${LDFLAGS}'
+ oe_runmake
}
do_install() {