aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-23 11:55:00 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-24 10:11:28 -0700
commite6d9392ebb2a666290b31c4a67d1c9205ce642ed (patch)
tree05946f3ee17b3f46fd0a941a2f106df34a5f7db4 /meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
parent4ef340551ff3e0ec74f1e10959108ba7e57f18c9 (diff)
downloadmeta-openembedded-contrib-e6d9392ebb2a666290b31c4a67d1c9205ce642ed.tar.gz
funyahoo-plusplus, icyque, pidgin-sipe, purple-skypeweb: add couple plugins for pidgin
* import from luneos to make pidgin here in meta-oe a bit more useful Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb')
-rw-r--r--meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb b/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
new file mode 100644
index 0000000000..3a437659e7
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Protocol plugin for New Yahoo (2016) for Adium, Pidgin, Miranda and Telepathy IM Framework"
+SECTION = "webos/services"
+LICENSE = "GPLv3.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+DEPENDS = "pidgin json-glib glib-2.0"
+
+inherit pkgconfig
+
+SRC_URI = "git://github.com/EionRobb/funyahoo-plusplus;branch=master;protocol=git"
+SRCREV = "fbbd9c591100aa00a0487738ec7b6acd3d924b3f"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" EXTRA_INCLUDES="${TARGET_CFLAGS}" AR="${AR}";
+}
+
+do_install() {
+ oe_runmake DESTDIR="${D}" install;
+}
+
+FILES_${PN} += " \
+ ${libdir} \
+"