aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-17 18:56:15 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-18 22:15:59 -0800
commitc011beeaa666cf02f952ef53630a0c2bc80bcc04 (patch)
tree7e6832cd5c0cf1f4ccdb665ddb410979e7206b0d /meta-oe/recipes-support/opensc/opensc_0.19.0.bb
parent014b90ee43b0b74086b4da3e3c9fcd0a5ecd830d (diff)
downloadmeta-openembedded-contrib-c011beeaa666cf02f952ef53630a0c2bc80bcc04.tar.gz
opensc: Upgrade to 0.19.0
Switch fetcher to use github Add patch to build with gcc9 Remove upstreamed patch Inherit bash-completion Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opensc/opensc_0.19.0.bb')
-rw-r--r--meta-oe/recipes-support/opensc/opensc_0.19.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opensc/opensc_0.19.0.bb b/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
new file mode 100644
index 0000000000..bc1722e394
--- /dev/null
+++ b/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Smart card library and applications"
+DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\
+functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\
+7816-4 compatible smart card. Encryption and decryption using private\
+keys on the smart card is possible with PKCS\
+such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\
+eID cards have also been confirmed to work."
+
+HOMEPAGE = "http://www.opensc-project.org/opensc/"
+SECTION = "System Environment/Libraries"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+
+#v0.19.0
+SRCREV = "f1691fc91fc113191c3a8aaf5facd6983334ec47"
+SRC_URI = "git://github.com/OpenSC/OpenSC \
+ file://0001-Remove-redundant-logging.patch \
+ "
+DEPENDS = "openct pcsc-lite virtual/libiconv openssl"
+
+S = "${WORKDIR}/git"
+inherit autotools pkgconfig bash-completion
+
+EXTRA_OECONF = " \
+ --disable-static \
+ --enable-openct \
+ --disable-pcsc \
+ --disable-ctapi \
+ --disable-doc \
+"
+EXTRA_OEMAKE = "DESTDIR=${D}"
+
+RDEPENDS_${PN} = "readline"
+
+FILES_${PN} += "\
+ ${libdir}/opensc-pkcs11.so \
+ ${libdir}/onepin-opensc-pkcs11.so \
+ ${libdir}/pkcs11-spy.so \
+"
+FILES_${PN}-dev += "\
+ ${libdir}/pkcs11/opensc-pkcs11.so \
+ ${libdir}/pkcs11/onepin-opensc-pkcs11.so \
+ ${libdir}/pkcs11/pkcs11-spy.so \
+"