aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv
diff options
context:
space:
mode:
authorIsmo Puustinen <ismo.puustinen@intel.com>2017-06-08 12:57:31 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:45 +0200
commit0abf5af3ffd3d13c009a8ffcd5a6f045c36be837 (patch)
treef811c101c61a7386aa01afb9b848200b84365313 /meta-oe/recipes-support/opencv
parent3b37c18838207c774501bc6d30c61bd935314d8b (diff)
downloadmeta-openembedded-contrib-0abf5af3ffd3d13c009a8ffcd5a6f045c36be837.tar.gz
opencv: fix runtime dependencies.
The newly split "libopencv-ts" package is empty (and thus not created), because all ts files are installed in the development package. So, do not add a runtime dependency to libopencv-ts. Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.2.bb b/meta-oe/recipes-support/opencv/opencv_3.2.bb
index 535c761fa5..fc62e99755 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.2.bb
@@ -126,7 +126,7 @@ python populate_packages_prepend () {
metapkg = pn
d.setVar('ALLOW_EMPTY_' + metapkg, "1")
- blacklist = [ metapkg ]
+ blacklist = [ metapkg, "libopencv-ts" ]
metapkg_rdepends = [ ]
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale') and not pkg.endswith('-staticdev'):