aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv_3.2.bb
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2017-05-02 14:46:55 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-09 16:01:24 +0200
commitc931bc6a7a2d25432fc10b7cdef3cf5ad922f6d5 (patch)
tree25cc2d964c9e0e2dcfbb1d83c309d1aa9e6b40e5 /meta-oe/recipes-support/opencv/opencv_3.2.bb
parent296fb498fba322539d36fdc8275a59684aa5a2cf (diff)
downloadmeta-openembedded-contrib-c931bc6a7a2d25432fc10b7cdef3cf5ad922f6d5.tar.gz
opencv: disable broken Intel FP16 detection
With opencv-3.2, the configuration detects if the target supports half-precision floating-point format. This fails to compile for some Intel targets such as skylake with an error such as: error: '_mm_cvtph_ps' was not declared in this scope The configuration used to work in opencv-3.1 so revert two commits to drop the FP16 detection even though it may make opencv slower. The only change in the configure log is: - FP16: Compiler support is available + FP16: Compiler support is not available The patch should be dropped when a newer version of opencv that includes commit: https://github.com/opencv/opencv/commit/e5d9b608c47d54e43496041595025fa282fa9de5 is available. Backporting that fix was complicated. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv_3.2.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.2.bb b/meta-oe/recipes-support/opencv/opencv_3.2.bb
index 2cff212ab0..98b6b06529 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.2.bb
@@ -27,6 +27,8 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
file://fixpkgconfig.patch \
file://uselocalxfeatures.patch;patchdir=../contrib/ \
file://useoeprotobuf.patch;patchdir=../contrib/ \
+ file://0001-Revert-cuda-fix-fp16-compilation.patch \
+ file://0002-Revert-check-FP16-build-condition-correctly.patch \
"
PV = "3.2+git${SRCPV}"