aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/open-vm-tools
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:41 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit6b0ac39453c7c39faf685747e60cb68754148e3c (patch)
tree1e1b00618fdc5a50e116c3c18724273be90d6e69 /meta-oe/recipes-support/open-vm-tools
parentb847bc1724b6d203d5eaea2d0e4e110648c2b51b (diff)
downloadmeta-openembedded-contrib-6b0ac39453c7c39faf685747e60cb68754148e3c.tar.gz
open-vm-tools: add missing X11 dependencies
Certain dependencies that are implied when we build with X11 support -- such as libxext -- were missing. Add them, and meanwhile switch to using PACKAGECONFIG[x11] instead of DISTRO_FEATURES. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/open-vm-tools')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index 2b2022864e..76d3840e66 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -47,11 +47,13 @@ KERNEL_MODULES_META_PACKAGE = "${PN}"
SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs --disable-tests \
- --without-gtk2 --without-gtkmm --without-xerces --without-pam \
+ --without-gtkmm --without-xerces --without-pam \
--disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
--with-linuxdir=${STAGING_KERNEL_DIR} --with-kernel-release=${KERNEL_VERSION} --without-root-privileges"
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '--without-x', d)}"
+NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
+X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
+PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
EXTRA_OEMAKE = "KERNEL_RELEASE=${KERNEL_VERSION}"