aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/open-vm-tools/open-vm-tools
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:32 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:24 +0200
commitd8e895ef7339cc94df2a57ee7f048efa9884e9cf (patch)
tree1f4dba46bf35ddb73797b7d28e293fdaaf017a22 /meta-oe/recipes-support/open-vm-tools/open-vm-tools
parentb460ac6bcb1cf4ab59df56cd0f5c2c91111199b6 (diff)
downloadmeta-openembedded-contrib-d8e895ef7339cc94df2a57ee7f048efa9884e9cf.tar.gz
open-vm-tools: add new recipe
This recipe is modified from the recipe originally found in the Open-Switch repository: https://github.com/open-switch/ops-build yocto/openswitch/meta-foss-openswitch/recipes-extended/open-vm-tools/open-vm-tools_10.0.5.bb Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9 Although the original recipe packaging was Apache-licensed, I received permission from the author (Diego Dompe) to relicense it under the MIT license for inclusion in meta-openembedded: https://lists.openswitch.net/pipermail/ops-dev/2017-April/014715.html https://lists.openswitch.net/pipermail/ops-dev/2017-April/014716.html Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/open-vm-tools/open-vm-tools')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch
new file mode 100644
index 0000000000..63ea453249
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch
@@ -0,0 +1,35 @@
+From 5d8814f4b4f016a633984822a6dfbc9426fef333 Mon Sep 17 00:00:00 2001
+From: Diego Dompe <dompe@hpe.com>
+Date: Thu, 7 Jan 2016 15:06:16 -0600
+Subject: [PATCH] Fix-kernel-detection
+
+Signed-off-by: Diego Dompe <dompe@hpe.com>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 04e3bac..1ab3f29 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -151,7 +151,7 @@ if test "$with_kernel_modules" = "yes"; then
+ if test ! -d "$LINUXDIR/kernel/"; then
+ AC_MSG_ERROR([$LINUXDIR/kernel does not exist])
+ fi
+- LINUXINCLUDE="$LINUXDIR/build/include"
++ LINUXINCLUDE="$LINUXDIR/include"
+ if test ! -d "$LINUXINCLUDE"; then
+ AC_MSG_ERROR([Can't find include dir under $LINUXDIR])
+ fi
+@@ -1034,7 +1034,7 @@ MODULES_DIR=""
+ buildHgfsmounter=no
+
+ if test "$os" = "linux"; then
+- MODULES_DIR="$LINUXDIR/kernel/"
++ MODULES_DIR="/lib/modules/$KERNEL_RELEASE"
+
+ CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64"
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
+--
+1.9.1
+