aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/onig
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2020-02-21 10:20:56 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-21 14:21:52 -0800
commit7513625706f28ef7bed57fb679d755ae0398a087 (patch)
treee88c3eb8aca6d4ae3827e0d2eaab63b184591107 /meta-oe/recipes-support/onig
parent664f8e13736b610c091c7f3855f655158b09333a (diff)
downloadmeta-openembedded-contrib-7513625706f28ef7bed57fb679d755ae0398a087.tar.gz
meta-oe: onig: avoid using 'install' with both -D and -t options
Older versions of 'install' (prior to 8.23) do not allow the -D and -t options to be used together. (see coreutils commit 15d092f94a3a [install: allow options -D and -t to be used together]). On build hosts such as CentOS7, which has install v8.22, we therefor see a failure: install: failed to access ‘...onig/6.9.4-r0/image/usr/lib64/onig/ptest/tests/’: No such file or directory We definitely don't want to avoid using useful features of tools but throughout meta-openembedded the mkdir approach is used so let's stick to it and avoid causing undo issues at the expense of one extra line of code. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/onig')
-rw-r--r--meta-oe/recipes-support/onig/onig_6.9.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/onig/onig_6.9.4.bb b/meta-oe/recipes-support/onig/onig_6.9.4.bb
index cfa86f04c1..50d9f52353 100644
--- a/meta-oe/recipes-support/onig/onig_6.9.4.bb
+++ b/meta-oe/recipes-support/onig/onig_6.9.4.bb
@@ -28,5 +28,6 @@ do_compile_ptest() {
}
do_install_ptest() {
- install -Dm0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/*
+ mkdir -p ${D}${PTEST_PATH}/tests
+ install -m 0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/*
}