aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-08-06 09:14:06 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:54:02 +0200
commit5003c4cc2d42575beca97e22a31b2d275ad5c558 (patch)
tree64c12d682dc00c6657b9f9b8746a8ccc75e9a445 /meta-oe/recipes-support/numactl
parentfe9d64dbf6a897de6813fe7a69ef305512c3d30b (diff)
downloadmeta-openembedded-contrib-5003c4cc2d42575beca97e22a31b2d275ad5c558.tar.gz
numactl: fix the ptest building
after upgrade, binary files are installed into test/.libs/, so fix the install ptest. redesign test Makefile rule Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl')
-rw-r--r--meta-oe/recipes-support/numactl/numactl/0001-define-run-test-target.patch32
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.10.bb21
2 files changed, 48 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl/0001-define-run-test-target.patch b/meta-oe/recipes-support/numactl/numactl/0001-define-run-test-target.patch
new file mode 100644
index 0000000000..78ffb22f89
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/0001-define-run-test-target.patch
@@ -0,0 +1,32 @@
+rename test target as run-test
+
+Upstream-Statue: Pending
+
+test target not only compile the test files, but also run them, which is
+not suitable for cross-compile environment, so rename it as run-test.
+
+and define test target to compile the test files.
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b6db339..de176c4 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -124,7 +124,9 @@ regress2: $(check_PROGRAMS)
+ test_numademo: numademo
+ ./numademo -t -e 10M
+
+-test: all $(check_PROGRAMS) regress1 regress2 test_numademo
++test: all $(check_PROGRAMS)
++
++run-test: all $(check_PROGRAMS) regress1 regress2 test_numademo
+
+ TESTS_ENVIRONMENT = builddir='$(builddir)'; export builddir;
+
+--
+1.9.1
+
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.10.bb b/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
index 3a10ebbeed..8f27b156bc 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.10.bb
@@ -15,6 +15,7 @@ SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
file://Fix-the-test-output-format.patch \
file://Makefile \
file://run-ptest \
+ file://0001-define-run-test-target.patch \
"
SRC_URI[md5sum] = "682c38305b2596967881f3d77bc3fc9c"
SRC_URI[sha256sum] = "dbdac8fe74f13b2e2864bba352f1597ab1d3345c8c485d7805f58d66f414db61"
@@ -28,19 +29,29 @@ do_install() {
rm -r ${D}${mandir}/man2
}
+do_compile_ptest() {
+ oe_runmake test
+}
+
do_install_ptest() {
#install tests binaries
- local test_binaries="checkaffinity checktopology distance \
- ftok mbind_mig_pages migrate_pages move_pages mynode \
- nodemap pagesize prefered printcpu randmap realloc_test \
- regress regress2 runltp shmtest tbitmap tshared bind_range"
+ local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
+ mynode nodemap node-parse pagesize prefered randmap realloc_test \
+ tbitmap tshared"
[ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
for i in $test_binaries; do
+ install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
+ done
+
+ local test_scripts="checktopology checkaffinity printcpu regress regress2 \
+ shmtest runltp bind_range"
+ for i in $test_scripts; do
install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
done
+
install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
- install -m 0755 ${B}/numactl ${D}${PTEST_PATH}/
+ install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
}
RDEPENDS_${PN}-ptest = "bash"