aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-08-19 14:46:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:12 +0200
commit4fc4326a0c7510d293b8108696beda4b395e0e2d (patch)
tree82f737ea424ae8fdafd3a1c156cf52bf7de018cc /meta-oe/recipes-support/mysql
parent3551575f9b69ca3d5f06321e444c9f8105c0a1b2 (diff)
downloadmeta-openembedded-contrib-4fc4326a0c7510d293b8108696beda4b395e0e2d.tar.gz
mariadb: update to 5.5.45
This is the latest release in the 5.5.x stable series. The CVE patch has been applied upstream. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mysql')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.5.45.bb (renamed from meta-oe/recipes-support/mysql/mariadb-native_5.5.43.bb)0
-rw-r--r--meta-oe/recipes-support/mysql/mariadb.inc17
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-CVE-2015-2305.patch43
-rw-r--r--meta-oe/recipes-support/mysql/mariadb_5.5.45.bb (renamed from meta-oe/recipes-support/mysql/mariadb_5.5.43.bb)0
4 files changed, 9 insertions, 51 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.5.43.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.5.45.bb
index 4ce960d7da..4ce960d7da 100644
--- a/meta-oe/recipes-support/mysql/mariadb-native_5.5.43.bb
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.5.45.bb
diff --git a/meta-oe/recipes-support/mysql/mariadb.inc b/meta-oe/recipes-support/mysql/mariadb.inc
index 4e2a64c895..cf004ad3a6 100644
--- a/meta-oe/recipes-support/mysql/mariadb.inc
+++ b/meta-oe/recipes-support/mysql/mariadb.inc
@@ -12,11 +12,10 @@ SRC_URI = "http://archive.mariadb.org/mariadb-${PV}/source/mariadb-${PV}.tar.gz
file://mysqld.service \
file://configure.cmake-fix-valgrind.patch \
file://fix-a-building-failure.patch \
- file://fix-CVE-2015-2305.patch \
"
-SRC_URI[md5sum] = "c8760d6b5890fc1de76c07af48092c88"
-SRC_URI[sha256sum] = "a0709997140549154edb87c9dfab564cd4755b238251acbf42369118f9bb4d01"
+SRC_URI[md5sum] = "6ec397f717f6e2e4e9154e76de9ec9fc"
+SRC_URI[sha256sum] = "4dc3aff6941ef1068412002915d795bcf67db0eaa38a5c6f3af57474c4226fb0"
S = "${WORKDIR}/mariadb-${PV}"
@@ -88,11 +87,13 @@ do_compile_prepend_class-target () {
cp ${STAGING_BINDIR_NATIVE}/comp_sql ${S}/scripts
if [ "${@bb.utils.contains('PACKAGECONFIG', 'krb5', 'yes', 'no', d)}" = "no" ]; then
- mkdir ${B}/include/openssl
- echo "#ifndef KSSL_H" >${B}/include/openssl/kssl.h
- echo "#define KSSL_H" >>${B}/include/openssl/kssl.h
- echo "#include <openssl/opensslconf.h>">>${B}/include/openssl/kssl.h
- echo "#endif" >>${B}/include/openssl/kssl.h
+ if ! [ -e ${B}/include/openssl/kssl.h ] ; then
+ mkdir -p ${B}/include/openssl
+ echo "#ifndef KSSL_H" >${B}/include/openssl/kssl.h
+ echo "#define KSSL_H" >>${B}/include/openssl/kssl.h
+ echo "#include <openssl/opensslconf.h>">>${B}/include/openssl/kssl.h
+ echo "#endif" >>${B}/include/openssl/kssl.h
+ fi
fi
}
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-CVE-2015-2305.patch b/meta-oe/recipes-support/mysql/mariadb/fix-CVE-2015-2305.patch
deleted file mode 100644
index 2d1b467343..0000000000
--- a/meta-oe/recipes-support/mysql/mariadb/fix-CVE-2015-2305.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From f5c1d00a9ceb61acfe038dcf2ec0236c2939328c Mon Sep 17 00:00:00 2001
-From: Roy Li <rongqing.li@windriver.com>
-Date: Mon, 1 Jun 2015 15:31:48 +0800
-Subject: [PATCH] From 70bc2965604b6b8aaf260049e64c708dddf85334 Mon Sep 17
- 00:00:00 2001 From: Gary Houston <ghouston@arglist.com> Date: Wed, 25 Feb
- 2015 13:29:03 +1100 Subject: [PATCH] Bug fix for integer overflow in regcomp
- for excessively long pattern strings. CERT Vulnerability Note VU#695940.
- Found by Guido Vranken.
-
-Upsteam-Status: Backport
-
-https://bugzilla.suse.com/attachment.cgi?id=627001
-
-Signed-off-by: Roy Li <rongqing.li@windriver.com>
----
- regex/regcomp.c | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/regex/regcomp.c b/regex/regcomp.c
-index abc1817..31e57c1 100644
---- a/regex/regcomp.c
-+++ b/regex/regcomp.c
-@@ -138,7 +138,16 @@ struct cclass cclasses[CCLASS_LAST+1]= {
- (NC-1)*sizeof(cat_t));
- if (g == NULL)
- return(REG_ESPACE);
-- p->ssize = (long) (len/(size_t)2*(size_t)3 + (size_t)1); /* ugh */
-+ {
-+ /* Patched for CERT Vulnerability Note VU#695940, Feb 2015. */
-+ size_t new_ssize = len/(size_t)2*(size_t)3 + (size_t)1; /* ugh */
-+ if (new_ssize < len || new_ssize > LONG_MAX / sizeof(sop)) {
-+ free((char *) g);
-+ return REG_INVARG;
-+ }
-+ p->ssize = new_ssize;
-+ }
-+
- p->strip = (sop *)malloc(p->ssize * sizeof(sop));
- p->slen = 0;
- if (p->strip == NULL) {
---
-1.9.1
-
diff --git a/meta-oe/recipes-support/mysql/mariadb_5.5.43.bb b/meta-oe/recipes-support/mysql/mariadb_5.5.45.bb
index 8f998a3a56..8f998a3a56 100644
--- a/meta-oe/recipes-support/mysql/mariadb_5.5.43.bb
+++ b/meta-oe/recipes-support/mysql/mariadb_5.5.45.bb