aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/mariadb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-05-10 18:54:00 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-27 16:39:31 +0100
commit72e23c12296fbc77193898c38426add58d0c2d71 (patch)
treeeed39116603d211504dabf316db4d42970b89871 /meta-oe/recipes-support/mysql/mariadb
parent336123c49e3d9a16429150dd96f60d423ccbd77b (diff)
downloadmeta-openembedded-contrib-72e23c12296fbc77193898c38426add58d0c2d71.tar.gz
mysql5: replace with mariadb 5.1.67 and tweak
Switch to MariaDB (which is a drop-in replacement for MySQL) and use the latest stable release from the 5.1 series. * Update LIC_FILES_CHKSUM due to reformatted GPLv2 license text with updated FSF address * Refresh patches * Add two patches from the upstream 5.1 branch to fix CVE-2013-1861 * Add a package for libmysqld (the embedded server library) * Disable "maria" plugin since this fails to compile and doesn't appear to be critical * Drop some unrecognised/redundant options from EXTRA_OECONF * Fix text relocation QA warnings introduced in the upgrade * Convert to use useradd.bbclass for creating mysql user * Set SUMMARY instead of description * Move SRC_URI checksums to the version-specific inc file * Clear out cruft in files/ Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support/mysql/mariadb')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/Makefile.am.patch19
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/configure-ps-cache-check.patch27
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/configure.in.patch13
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-1.patch174
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-2.patch257
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix_host_path.patch37
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/misc.m4.patch13
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/my.cnf21
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/mysqld.sh24
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/plug.in.patch405
10 files changed, 990 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb/Makefile.am.patch b/meta-oe/recipes-support/mysql/mariadb/Makefile.am.patch
new file mode 100644
index 0000000000..33fd17acd4
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/Makefile.am.patch
@@ -0,0 +1,19 @@
+Index: mysql-5.1.40/sql/Makefile.am
+===================================================================
+--- mysql-5.1.40.orig/sql/Makefile.am
++++ mysql-5.1.40/sql/Makefile.am
+@@ -174,10 +174,10 @@ link_sources:
+ # This generates lex_hash.h
+ # NOTE Built sources should depend on their sources not the tool
+ # this avoid the rebuild of the built files in a source dist
+-lex_hash.h: gen_lex_hash.cc lex.h
+- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@-t
+- $(MV) $@-t $@
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
++lex_hash.h: gen_lex_hash$(EXEEXT)
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so
+ udf_example_la_SOURCES= udf_example.c
diff --git a/meta-oe/recipes-support/mysql/mariadb/configure-ps-cache-check.patch b/meta-oe/recipes-support/mysql/mariadb/configure-ps-cache-check.patch
new file mode 100644
index 0000000000..3b5b3fd063
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/configure-ps-cache-check.patch
@@ -0,0 +1,27 @@
+Index: mysql-4.1.22/configure.in
+===================================================================
+--- mysql-4.1.22.orig/configure.in 2009-01-28 16:33:28.000000000 +0000
++++ mysql-4.1.22/configure.in 2009-01-28 16:43:26.000000000 +0000
+@@ -471,8 +471,8 @@
+
+ # Lock for PS
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS p $$ 2> /dev/null | grep $0 > /dev/null
+ then
+@@ -511,8 +511,9 @@
+ AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)
diff --git a/meta-oe/recipes-support/mysql/mariadb/configure.in.patch b/meta-oe/recipes-support/mysql/mariadb/configure.in.patch
new file mode 100644
index 0000000000..6fe2dfaa1a
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/configure.in.patch
@@ -0,0 +1,13 @@
+Index: mysql-5.1.40/configure.in
+===================================================================
+--- mysql-5.1.40.orig/configure.in
++++ mysql-5.1.40/configure.in
+@@ -226,8 +226,6 @@ else
+ AC_PATH_PROG(AS, as, as)
+ fi
+
+-# Still need ranlib for readline; local static use only so no libtool.
+-AC_PROG_RANLIB
+ # We use libtool
+ #AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-1.patch b/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-1.patch
new file mode 100644
index 0000000000..df2e7086c4
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-1.patch
@@ -0,0 +1,174 @@
+From 24404044ad4c28026e400e1fcd85358f2060aa96 Mon Sep 17 00:00:00 2001
+From: Alexey Botchkov <holyfoot@askmonty.org>
+Date: Sun, 10 Mar 2013 23:08:05 +0400
+Subject: [PATCH] MDEV-4252 geometry query crashes server. The bug was
+ found by Alyssa Milburn. If the number of points of a geometry feature
+ read from binary representation is greater than 0x10000000, then
+ the (uint32) (num_points * 16) will cut the higher byte, which leads to
+ various errors. Fixed by additional check if (num_points >
+ max_n_points).
+
+Upstream-Status: Backport
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+---
+ mysql-test/r/gis.result | 3 +++
+ mysql-test/t/gis.test | 1 +
+ sql/spatial.cc | 27 ++++++++++++++++++---------
+ sql/spatial.h | 9 +++++----
+ 4 files changed, 27 insertions(+), 13 deletions(-)
+
+diff --git a/mysql-test/r/gis.result b/mysql-test/r/gis.result
+index 8dad72f..69e73d0 100644
+--- a/mysql-test/r/gis.result
++++ b/mysql-test/r/gis.result
+@@ -1087,4 +1087,7 @@ NULL
+ #
+ SELECT GEOMETRYCOLLECTION((SELECT @@OLD));
+ ERROR 22007: Illegal non geometric '' value found during parsing
++select astext(0x0100000000030000000100000000000010);
++astext(0x0100000000030000000100000000000010)
++NULL
+ End of 5.1 tests
+diff --git a/mysql-test/t/gis.test b/mysql-test/t/gis.test
+index abda3e9..cc5d158 100644
+--- a/mysql-test/t/gis.test
++++ b/mysql-test/t/gis.test
+@@ -826,5 +826,6 @@ SELECT ISCLOSED(CONVERT(CONCAT(' ', 0x2), BINARY(20)));
+ --error ER_ILLEGAL_VALUE_FOR_TYPE
+ SELECT GEOMETRYCOLLECTION((SELECT @@OLD));
+
++select astext(0x0100000000030000000100000000000010);
+
+ --echo End of 5.1 tests
+diff --git a/sql/spatial.cc b/sql/spatial.cc
+index eec028e..94d0238 100644
+--- a/sql/spatial.cc
++++ b/sql/spatial.cc
+@@ -556,7 +556,7 @@ bool Gis_line_string::get_data_as_wkt(String *txt, const char **end) const
+ n_points= uint4korr(data);
+ data += 4;
+
+- if (n_points < 1 ||
++ if (n_points < 1 || n_points > max_n_points ||
+ no_data(data, SIZEOF_STORED_DOUBLE * 2 * n_points) ||
+ txt->reserve(((MAX_DIGITS_IN_DOUBLE + 1)*2 + 1) * n_points))
+ return 1;
+@@ -594,7 +594,8 @@ int Gis_line_string::geom_length(double *len) const
+ return 1;
+ n_points= uint4korr(data);
+ data+= 4;
+- if (n_points < 1 || no_data(data, SIZEOF_STORED_DOUBLE * 2 * n_points))
++ if (n_points < 1 || n_points > max_n_points ||
++ no_data(data, SIZEOF_STORED_DOUBLE * 2 * n_points))
+ return 1;
+
+ get_point(&prev_x, &prev_y, data);
+@@ -628,7 +629,7 @@ int Gis_line_string::is_closed(int *closed) const
+ return 0;
+ }
+ data+= 4;
+- if (n_points == 0 ||
++ if (n_points == 0 || n_points > max_n_points ||
+ no_data(data, SIZEOF_STORED_DOUBLE * 2 * n_points))
+ return 1;
+
+@@ -798,7 +799,8 @@ bool Gis_polygon::get_data_as_wkt(String *txt, const char **end) const
+ return 1;
+ n_points= uint4korr(data);
+ data+= 4;
+- if (no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points) ||
++ if (n_points > max_n_points ||
++ no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points) ||
+ txt->reserve(2 + ((MAX_DIGITS_IN_DOUBLE + 1) * 2 + 1) * n_points))
+ return 1;
+ txt->qs_append('(');
+@@ -852,7 +854,8 @@ int Gis_polygon::area(double *ar, const char **end_of_data) const
+ if (no_data(data, 4))
+ return 1;
+ n_points= uint4korr(data);
+- if (no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points))
++ if (n_points > max_n_points ||
++ no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points))
+ return 1;
+ get_point(&prev_x, &prev_y, data+4);
+ data+= (4+SIZEOF_STORED_DOUBLE*2);
+@@ -888,7 +891,8 @@ int Gis_polygon::exterior_ring(String *result) const
+ n_points= uint4korr(data);
+ data+= 4;
+ length= n_points * POINT_DATA_SIZE;
+- if (no_data(data, length) || result->reserve(1+4+4+ length))
++ if (n_points > max_n_points ||
++ no_data(data, length) || result->reserve(1+4+4+ length))
+ return 1;
+
+ result->q_append((char) wkb_ndr);
+@@ -973,7 +977,8 @@ int Gis_polygon::centroid_xy(double *x, double *y) const
+ return 1;
+ org_n_points= n_points= uint4korr(data);
+ data+= 4;
+- if (no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points))
++ if (n_points > max_n_points ||
++ no_data(data, (SIZEOF_STORED_DOUBLE*2) * n_points))
+ return 1;
+ get_point(&prev_x, &prev_y, data);
+ data+= (SIZEOF_STORED_DOUBLE*2);
+@@ -1260,7 +1265,8 @@ bool Gis_multi_line_string::get_data_as_wkt(String *txt,
+ return 1;
+ n_points= uint4korr(data + WKB_HEADER_SIZE);
+ data+= WKB_HEADER_SIZE + 4;
+- if (no_data(data, n_points * (SIZEOF_STORED_DOUBLE*2)) ||
++ if (n_points > max_n_points ||
++ no_data(data, n_points * (SIZEOF_STORED_DOUBLE*2)) ||
+ txt->reserve(2 + ((MAX_DIGITS_IN_DOUBLE + 1) * 2 + 1) * n_points))
+ return 1;
+ txt->qs_append('(');
+@@ -1521,7 +1527,8 @@ bool Gis_multi_polygon::get_data_as_wkt(String *txt, const char **end) const
+ return 1;
+ uint32 n_points= uint4korr(data);
+ data+= 4;
+- if (no_data(data, (SIZEOF_STORED_DOUBLE * 2) * n_points) ||
++ if (n_points > max_n_points ||
++ no_data(data, (SIZEOF_STORED_DOUBLE * 2) * n_points) ||
+ txt->reserve(2 + ((MAX_DIGITS_IN_DOUBLE + 1) * 2 + 1) * n_points,
+ 512))
+ return 1;
+@@ -1604,6 +1611,8 @@ int Gis_multi_polygon::geometry_n(uint32 num, String *result) const
+ if (no_data(data, 4))
+ return 1;
+ n_points= uint4korr(data);
++ if (n_points > max_n_points)
++ return 1;
+ data+= 4 + POINT_DATA_SIZE * n_points;
+ }
+ } while (--num);
+diff --git a/sql/spatial.h b/sql/spatial.h
+index 20b3856..7d25425 100644
+--- a/sql/spatial.h
++++ b/sql/spatial.h
+@@ -197,6 +197,11 @@ struct MBR
+ class Geometry
+ {
+ public:
++ // Maximum number of points in feature that can fit into String
++ static const uint32 max_n_points=
++ (uint32) (UINT_MAX32 - WKB_HEADER_SIZE - 4 /* n_points */) /
++ POINT_DATA_SIZE;
++public:
+ Geometry() {} /* Remove gcc warning */
+ virtual ~Geometry() {} /* Remove gcc warning */
+ static void *operator new(size_t size, void *buffer)
+@@ -379,10 +384,6 @@ class Gis_point: public Geometry
+
+ class Gis_line_string: public Geometry
+ {
+- // Maximum number of points in LineString that can fit into String
+- static const uint32 max_n_points=
+- (uint32) (UINT_MAX32 - WKB_HEADER_SIZE - 4 /* n_points */) /
+- POINT_DATA_SIZE;
+ public:
+ Gis_line_string() {} /* Remove gcc warning */
+ virtual ~Gis_line_string() {} /* Remove gcc warning */
+--
+1.8.1.6
+
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-2.patch b/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-2.patch
new file mode 100644
index 0000000000..c35cdfb641
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix-cve-2013-1861-2.patch
@@ -0,0 +1,257 @@
+From 9f714cdd3bf4bd8ee06cd38dcd2c6e8990a4ec48 Mon Sep 17 00:00:00 2001
+From: Alexey Botchkov <holyfoot@askmonty.org>
+Date: Mon, 18 Mar 2013 17:58:00 +0400
+Subject: [PATCH] MDEV-4252 geometry query crashes server. Additional fixes
+ for possible overflows in length-related calculations in 'spatial'
+ implementations. Checks added to the ::get_data_size() methods.
+ max_n_points decreased to occupy less 2G size. An object of that size is
+ practically inoperable anyway.
+
+Upstream-Status: Backport
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+---
+ mysql-test/r/gis.result | 12 +++++++++
+ mysql-test/t/gis.test | 6 +++++
+ sql/spatial.cc | 67 ++++++++++++++++++++++++++++++++++---------------
+ sql/spatial.h | 2 +-
+ 4 files changed, 66 insertions(+), 21 deletions(-)
+
+diff --git a/mysql-test/r/gis.result b/mysql-test/r/gis.result
+index 69e73d0..7566f0b 100644
+--- a/mysql-test/r/gis.result
++++ b/mysql-test/r/gis.result
+@@ -1087,7 +1087,19 @@ NULL
+ #
+ SELECT GEOMETRYCOLLECTION((SELECT @@OLD));
+ ERROR 22007: Illegal non geometric '' value found during parsing
++#
++# MDEV-4252 geometry query crashes server
++#
+ select astext(0x0100000000030000000100000000000010);
+ astext(0x0100000000030000000100000000000010)
+ NULL
++select envelope(0x0100000000030000000100000000000010);
++envelope(0x0100000000030000000100000000000010)
++NULL
++select geometryn(0x0100000000070000000100000001030000000200000000000000ffff0000, 1);
++geometryn(0x0100000000070000000100000001030000000200000000000000ffff0000, 1)
++NULL
++select geometryn(0x0100000000070000000100000001030000000200000000000000ffffff0f, 1);
++geometryn(0x0100000000070000000100000001030000000200000000000000ffffff0f, 1)
++NULL
+ End of 5.1 tests
+diff --git a/mysql-test/t/gis.test b/mysql-test/t/gis.test
+index cc5d158..c42541e 100644
+--- a/mysql-test/t/gis.test
++++ b/mysql-test/t/gis.test
+@@ -826,6 +826,12 @@ SELECT ISCLOSED(CONVERT(CONCAT(' ', 0x2), BINARY(20)));
+ --error ER_ILLEGAL_VALUE_FOR_TYPE
+ SELECT GEOMETRYCOLLECTION((SELECT @@OLD));
+
++--echo #
++--echo # MDEV-4252 geometry query crashes server
++--echo #
+ select astext(0x0100000000030000000100000000000010);
++select envelope(0x0100000000030000000100000000000010);
++select geometryn(0x0100000000070000000100000001030000000200000000000000ffff0000, 1);
++select geometryn(0x0100000000070000000100000001030000000200000000000000ffffff0f, 1);
+
+ --echo End of 5.1 tests
+diff --git a/sql/spatial.cc b/sql/spatial.cc
+index 94d0238..5a4b768 100644
+--- a/sql/spatial.cc
++++ b/sql/spatial.cc
+@@ -394,18 +394,19 @@ const char *Geometry::append_points(String *txt, uint32 n_points,
+ const char *Geometry::get_mbr_for_points(MBR *mbr, const char *data,
+ uint offset) const
+ {
+- uint32 points;
++ uint32 n_points;
+ /* read number of points */
+ if (no_data(data, 4))
+ return 0;
+- points= uint4korr(data);
++ n_points= uint4korr(data);
+ data+= 4;
+
+- if (no_data(data, (SIZEOF_STORED_DOUBLE * 2 + offset) * points))
++ if (n_points > max_n_points ||
++ no_data(data, (POINT_DATA_SIZE + offset) * n_points))
+ return 0;
+
+ /* Calculate MBR for points */
+- while (points--)
++ while (n_points--)
+ {
+ data+= offset;
+ mbr->add_xy(data, data + SIZEOF_STORED_DOUBLE);
+@@ -484,9 +485,12 @@ const Geometry::Class_info *Gis_point::get_class_info() const
+
+ uint32 Gis_line_string::get_data_size() const
+ {
+- if (no_data(m_data, 4))
++ uint32 n_points, size;
++ if (no_data(m_data, 4) ||
++ (n_points= uint4korr(m_data)) > max_n_points ||
++ no_data(m_data, (size= 4 + n_points * POINT_DATA_SIZE)))
+ return GET_SIZE_ERROR;
+- return 4 + uint4korr(m_data) * POINT_DATA_SIZE;
++ return size;
+ }
+
+
+@@ -665,6 +669,9 @@ int Gis_line_string::end_point(String *result) const
+ if (no_data(m_data, 4))
+ return 1;
+ n_points= uint4korr(m_data);
++ if (n_points == 0 || n_points > max_n_points ||
++ no_data(m_data, POINT_DATA_SIZE * n_points))
++ return 1;
+ return create_point(result, m_data + 4 + (n_points - 1) * POINT_DATA_SIZE);
+ }
+
+@@ -674,11 +681,14 @@ int Gis_line_string::point_n(uint32 num, String *result) const
+ uint32 n_points;
+ if (no_data(m_data, 4))
+ return 1;
++ num--;
+ n_points= uint4korr(m_data);
+- if ((uint32) (num - 1) >= n_points) // means (num > n_points || num < 1)
++ if (num >= n_points ||
++ num > max_n_points || // means (num > n_points || num < 1)
++ no_data(m_data, num * POINT_DATA_SIZE))
+ return 1;
+
+- return create_point(result, m_data + 4 + (num - 1) * POINT_DATA_SIZE);
++ return create_point(result, m_data + 4 + num*POINT_DATA_SIZE);
+ }
+
+ const Geometry::Class_info *Gis_line_string::get_class_info() const
+@@ -692,6 +702,7 @@ const Geometry::Class_info *Gis_line_string::get_class_info() const
+ uint32 Gis_polygon::get_data_size() const
+ {
+ uint32 n_linear_rings;
++ uint32 n_points;
+ const char *data= m_data;
+
+ if (no_data(data, 4))
+@@ -701,10 +712,13 @@ uint32 Gis_polygon::get_data_size() const
+
+ while (n_linear_rings--)
+ {
+- if (no_data(data, 4))
++ if (no_data(data, 4) ||
++ (n_points= uint4korr(data)) > max_n_points)
+ return GET_SIZE_ERROR;
+- data+= 4 + uint4korr(data)*POINT_DATA_SIZE;
++ data+= 4 + n_points*POINT_DATA_SIZE;
+ }
++ if (no_data(data, 0))
++ return GET_SIZE_ERROR;
+ return (uint32) (data - m_data);
+ }
+
+@@ -1037,9 +1051,14 @@ const Geometry::Class_info *Gis_polygon::get_class_info() const
+
+ uint32 Gis_multi_point::get_data_size() const
+ {
+- if (no_data(m_data, 4))
+- return GET_SIZE_ERROR;
+- return 4 + uint4korr(m_data)*(POINT_DATA_SIZE + WKB_HEADER_SIZE);
++ uint32 n_points;
++ uint32 size;
++
++ if (no_data(m_data, 4) ||
++ (n_points= uint4korr(m_data)) > max_n_points ||
++ no_data(m_data, (size= 4 + n_points*(POINT_DATA_SIZE + WKB_HEADER_SIZE))))
++ return GET_SIZE_ERROR;
++ return size;
+ }
+
+
+@@ -1107,7 +1126,8 @@ bool Gis_multi_point::get_data_as_wkt(String *txt, const char **end) const
+ return 1;
+
+ n_points= uint4korr(m_data);
+- if (no_data(m_data+4,
++ if (n_points > max_n_points ||
++ no_data(m_data+4,
+ n_points * (SIZEOF_STORED_DOUBLE * 2 + WKB_HEADER_SIZE)) ||
+ txt->reserve(((MAX_DIGITS_IN_DOUBLE + 1) * 2 + 1) * n_points))
+ return 1;
+@@ -1160,6 +1180,7 @@ const Geometry::Class_info *Gis_multi_point::get_class_info() const
+ uint32 Gis_multi_line_string::get_data_size() const
+ {
+ uint32 n_line_strings;
++ uint32 n_points;
+ const char *data= m_data;
+
+ if (no_data(data, 4))
+@@ -1169,11 +1190,13 @@ uint32 Gis_multi_line_string::get_data_size() const
+
+ while (n_line_strings--)
+ {
+- if (no_data(data, WKB_HEADER_SIZE + 4))
++ if (no_data(data, WKB_HEADER_SIZE + 4) ||
++ (n_points= uint4korr(data + WKB_HEADER_SIZE)) > max_n_points)
+ return GET_SIZE_ERROR;
+- data+= (WKB_HEADER_SIZE + 4 + uint4korr(data + WKB_HEADER_SIZE) *
+- POINT_DATA_SIZE);
++ data+= (WKB_HEADER_SIZE + 4 + n_points*POINT_DATA_SIZE);
+ }
++ if (no_data(data, 0))
++ return GET_SIZE_ERROR;
+ return (uint32) (data - m_data);
+ }
+
+@@ -1327,7 +1350,7 @@ int Gis_multi_line_string::geometry_n(uint32 num, String *result) const
+ return 1;
+ n_points= uint4korr(data + WKB_HEADER_SIZE);
+ length= WKB_HEADER_SIZE + 4+ POINT_DATA_SIZE * n_points;
+- if (no_data(data, length))
++ if (n_points > max_n_points || no_data(data, length))
+ return 1;
+ if (!--num)
+ break;
+@@ -1407,6 +1430,7 @@ const Geometry::Class_info *Gis_multi_line_string::get_class_info() const
+ uint32 Gis_multi_polygon::get_data_size() const
+ {
+ uint32 n_polygons;
++ uint32 n_points;
+ const char *data= m_data;
+
+ if (no_data(data, 4))
+@@ -1425,11 +1449,14 @@ uint32 Gis_multi_polygon::get_data_size() const
+
+ while (n_linear_rings--)
+ {
+- if (no_data(data, 4))
++ if (no_data(data, 4) ||
++ (n_points= uint4korr(data)) > max_n_points)
+ return GET_SIZE_ERROR;
+- data+= 4 + uint4korr(data) * POINT_DATA_SIZE;
++ data+= 4 + n_points * POINT_DATA_SIZE;
+ }
+ }
++ if (no_data(data, 0))
++ return GET_SIZE_ERROR;
+ return (uint32) (data - m_data);
+ }
+
+diff --git a/sql/spatial.h b/sql/spatial.h
+index 7d25425..d7632c1 100644
+--- a/sql/spatial.h
++++ b/sql/spatial.h
+@@ -199,7 +199,7 @@ class Geometry
+ public:
+ // Maximum number of points in feature that can fit into String
+ static const uint32 max_n_points=
+- (uint32) (UINT_MAX32 - WKB_HEADER_SIZE - 4 /* n_points */) /
++ (uint32) (INT_MAX32 - WKB_HEADER_SIZE - 4 /* n_points */) /
+ POINT_DATA_SIZE;
+ public:
+ Geometry() {} /* Remove gcc warning */
+--
+1.8.1.6
+
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix_host_path.patch b/meta-oe/recipes-support/mysql/mariadb/fix_host_path.patch
new file mode 100644
index 0000000000..4f69cd5198
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix_host_path.patch
@@ -0,0 +1,37 @@
+--- mysql-4.1.22/configure.in.old 2008-09-18 20:11:15.000000000 -0500
++++ mysql-4.1.22/configure.in 2008-09-18 20:12:28.000000000 -0500
+@@ -456,9 +456,9 @@ else
+ fi
+ fi
+
+-AC_SUBST(HOSTNAME)
+-AC_SUBST(PERL)
+-AC_SUBST(PERL5)
++AC_SUBST(HOSTNAME,/bin/hostname)
++AC_SUBST(PERL,$(bindir)/perl)
++AC_SUBST(PERL5,$(bindir)/perl)
+
+ # for build ndb docs
+
+@@ -516,16 +516,17 @@ AC_MSG_RESULT("$FIND_PROC")
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)
++AC_SUBST(KILL,/bin/kill)
+ AC_MSG_CHECKING("for kill switches")
+-if $ac_cv_path_KILL -0 $$
++if $KILL -0 $$
+ then
+- CHECK_PID="$ac_cv_path_KILL -0 \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -0 \$\$PID > /dev/null 2> /dev/null"
+ elif kill -s 0 $$
+ then
+- CHECK_PID="$ac_cv_path_KILL -s 0 \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -s 0 \$\$PID > /dev/null 2> /dev/null"
+ else
+ AC_MSG_WARN([kill -0 to check for pid seems to fail])
+- CHECK_PID="$ac_cv_path_KILL -s SIGCONT \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -s SIGCONT \$\$PID > /dev/null 2> /dev/null"
+ fi
+ AC_SUBST(CHECK_PID)
+ AC_MSG_RESULT("$CHECK_PID")
diff --git a/meta-oe/recipes-support/mysql/mariadb/misc.m4.patch b/meta-oe/recipes-support/mysql/mariadb/misc.m4.patch
new file mode 100644
index 0000000000..7b0acff21c
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/misc.m4.patch
@@ -0,0 +1,13 @@
+Index: mysql-5.1.40/config/ac-macros/misc.m4
+===================================================================
+--- mysql-5.1.40.orig/config/ac-macros/misc.m4
++++ mysql-5.1.40/config/ac-macros/misc.m4
+@@ -476,7 +476,7 @@ AC_DEFUN([MYSQL_STACK_DIRECTION],
+ {
+ exit (find_stack_direction() < 0);
+ }], ac_cv_c_stack_direction=1, ac_cv_c_stack_direction=-1,
+- ac_cv_c_stack_direction=)])
++ ac_cv_c_stack_direction=0)])
+ AC_DEFINE_UNQUOTED(STACK_DIRECTION, $ac_cv_c_stack_direction)
+ ])dnl
+
diff --git a/meta-oe/recipes-support/mysql/mariadb/my.cnf b/meta-oe/recipes-support/mysql/mariadb/my.cnf
new file mode 100644
index 0000000000..84708170ad
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/my.cnf
@@ -0,0 +1,21 @@
+[client]
+#password = password
+port = 3306
+socket = /tmp/mysql.sock
+
+[mysqld_safe]
+err-log = /var/log/mysql.err
+
+[mysqld]
+user = mysql
+port = 3306
+socket = /tmp/mysql.sock
+pid-file = /var/lib/mysql/mysqld.pid
+log-error = /var/log/mysqld.err
+basedir = /usr
+datadir = /var/mysql
+skip-locking
+skip-networking
+ignore-builtin-innodb
+bind-address = localhost
+
diff --git a/meta-oe/recipes-support/mysql/mariadb/mysqld.sh b/meta-oe/recipes-support/mysql/mariadb/mysqld.sh
new file mode 100644
index 0000000000..479ebdb257
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/mysqld.sh
@@ -0,0 +1,24 @@
+# MySQL init script
+
+. /etc/default/rcS
+
+case "$1" in
+ start)
+ /usr/bin/mysqld_safe &
+ ;;
+ stop)
+ if test -f /var/lib/mysql/mysqld.pid ; then
+ PID=`cat /var/lib/mysql/mysqld.pid`
+ kill $PID
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/mysqld {start|stop|restart}"
+ ;;
+esac
+
+exit 0
diff --git a/meta-oe/recipes-support/mysql/mariadb/plug.in.patch b/meta-oe/recipes-support/mysql/mariadb/plug.in.patch
new file mode 100644
index 0000000000..156fd10823
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/plug.in.patch
@@ -0,0 +1,405 @@
+diff --git a/storage/innodb_plugin/plug.in b/storage/innodb_plugin/plug.in
+index 7650251..3cc22c5 100644
+--- a/storage/innodb_plugin/plug.in
++++ b/storage/innodb_plugin/plug.in
+@@ -56,180 +56,10 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
+ esac
+ AC_SUBST(INNODB_DYNAMIC_CFLAGS)
+
+- AC_MSG_CHECKING(whether GCC atomic builtins are available)
+- # either define HAVE_IB_GCC_ATOMIC_BUILTINS or not
+- AC_TRY_RUN(
+- [
+- int main()
+- {
+- long x;
+- long y;
+- long res;
+- char c;
+-
+- x = 10;
+- y = 123;
+- res = __sync_bool_compare_and_swap(&x, x, y);
+- if (!res || x != y) {
+- return(1);
+- }
+-
+- x = 10;
+- y = 123;
+- res = __sync_bool_compare_and_swap(&x, x + 1, y);
+- if (res || x != 10) {
+- return(1);
+- }
+-
+- x = 10;
+- y = 123;
+- res = __sync_add_and_fetch(&x, y);
+- if (res != 123 + 10 || x != 123 + 10) {
+- return(1);
+- }
+-
+- c = 10;
+- res = __sync_lock_test_and_set(&c, 123);
+- if (res != 10 || c != 123) {
+- return(1);
+- }
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_GCC_ATOMIC_BUILTINS], [1],
+- [GCC atomic builtins are available])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+- AC_MSG_CHECKING(whether pthread_t can be used by GCC atomic builtins)
+- # either define HAVE_IB_ATOMIC_PTHREAD_T_GCC or not
+- AC_TRY_RUN(
+- [
+- #include <pthread.h>
+- #include <string.h>
+-
+- int main(int argc, char** argv) {
+- pthread_t x1;
+- pthread_t x2;
+- pthread_t x3;
+-
+- memset(&x1, 0x0, sizeof(x1));
+- memset(&x2, 0x0, sizeof(x2));
+- memset(&x3, 0x0, sizeof(x3));
+-
+- __sync_bool_compare_and_swap(&x1, x2, x3);
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_ATOMIC_PTHREAD_T_GCC], [1],
+- [pthread_t can be used by GCC atomic builtins])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+- AC_MSG_CHECKING(whether Solaris libc atomic functions are available)
+- # Define HAVE_IB_SOLARIS_ATOMICS if _all_ of the following
+- # functions are present.
+- AC_CHECK_FUNCS(atomic_add_long_nv \
+- atomic_cas_32 \
+- atomic_cas_64 \
+- atomic_cas_ulong \
+- atomic_swap_uchar)
+-
+- if test "${ac_cv_func_atomic_add_long_nv}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_32}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_64}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_ulong}" = "yes" -a \
+- "${ac_cv_func_atomic_swap_uchar}" = "yes" ; then
+-
+- AC_DEFINE([HAVE_IB_SOLARIS_ATOMICS], [1],
+- [Define to 1 if Solaris libc atomic functions are available]
+- )
+- fi
+-
+- AC_MSG_CHECKING(whether pthread_t can be used by Solaris libc atomic functions)
+- # either define HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS or not
+- AC_TRY_RUN(
+- [
+- #include <pthread.h>
+- #include <string.h>
+-
+- int main(int argc, char** argv) {
+- pthread_t x1;
+- pthread_t x2;
+- pthread_t x3;
+-
+- memset(&x1, 0x0, sizeof(x1));
+- memset(&x2, 0x0, sizeof(x2));
+- memset(&x3, 0x0, sizeof(x3));
+-
+- if (sizeof(pthread_t) == 4) {
+-
+- atomic_cas_32(&x1, x2, x3);
+-
+- } else if (sizeof(pthread_t) == 8) {
+-
+- atomic_cas_64(&x1, x2, x3);
+-
+- } else {
+-
+- return(1);
+- }
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS], [1],
+- [pthread_t can be used by solaris atomics])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+ # this is needed to know which one of atomic_cas_32() or atomic_cas_64()
+ # to use in the source
+ AC_CHECK_SIZEOF([pthread_t], [], [#include <pthread.h>])
+
+- # Check for x86 PAUSE instruction
+- AC_MSG_CHECKING(for x86 PAUSE instruction)
+- # We have to actually try running the test program, because of a bug
+- # in Solaris on x86_64, where it wrongly reports that PAUSE is not
+- # supported when trying to run an application. See
+- # http://bugs.opensolaris.org/bugdatabase/printableBug.do?bug_id=6478684
+- # We use ib_ prefix to avoid collisoins if this code is added to
+- # mysql's configure.in.
+- AC_TRY_RUN(
+- [
+- int main() {
+- __asm__ __volatile__ ("pause");
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_PAUSE_INSTRUCTION], [1], [Does x86 PAUSE instruction exist])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+ ])
+
+ # vim: set ft=config:
+diff --git a/storage/xtradb/plug.in b/storage/xtradb/plug.in
+index 3fadacc..a33f4dc 100644
+--- a/storage/xtradb/plug.in
++++ b/storage/xtradb/plug.in
+@@ -56,215 +56,10 @@ MYSQL_PLUGIN_ACTIONS(xtradb, [
+ esac
+ AC_SUBST(INNODB_DYNAMIC_CFLAGS)
+
+- AC_MSG_CHECKING(whether GCC atomic builtins are available)
+- # either define HAVE_IB_GCC_ATOMIC_BUILTINS or not
+- AC_TRY_RUN(
+- [
+- int main()
+- {
+- long x;
+- long y;
+- long res;
+- char c;
+-
+- x = 10;
+- y = 123;
+- res = __sync_bool_compare_and_swap(&x, x, y);
+- if (!res || x != y) {
+- return(1);
+- }
+-
+- x = 10;
+- y = 123;
+- res = __sync_bool_compare_and_swap(&x, x + 1, y);
+- if (res || x != 10) {
+- return(1);
+- }
+-
+- x = 10;
+- y = 123;
+- res = __sync_add_and_fetch(&x, y);
+- if (res != 123 + 10 || x != 123 + 10) {
+- return(1);
+- }
+-
+- c = 10;
+- res = __sync_lock_test_and_set(&c, 123);
+- if (res != 10 || c != 123) {
+- return(1);
+- }
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_GCC_ATOMIC_BUILTINS], [1],
+- [GCC atomic builtins are available])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+- AC_MSG_CHECKING(whether GCC 64-bit atomic builtins are available)
+- # either define HAVE_IB_GCC_ATOMIC_BUILTINS_64 or not
+- AC_TRY_RUN(
+- [
+- #include <stdint.h>
+- int main()
+- {
+- int64_t x, y, res;
+-
+- x = 10;
+- y = 123;
+- res = __sync_bool_compare_and_swap(&x, x, y);
+- if (!res || x != y) {
+- return(1);
+- }
+-
+- x = 10;
+- y = 123;
+- res = __sync_add_and_fetch(&x, y);
+- if (res != 123 + 10 || x != 123 + 10) {
+- return(1);
+- }
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_GCC_ATOMIC_BUILTINS_64], [1],
+- [GCC 64-bit atomic builtins are available])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+- AC_MSG_CHECKING(whether pthread_t can be used by GCC atomic builtins)
+- # either define HAVE_IB_ATOMIC_PTHREAD_T_GCC or not
+- AC_TRY_RUN(
+- [
+- #include <pthread.h>
+- #include <string.h>
+-
+- int main(int argc, char** argv) {
+- pthread_t x1;
+- pthread_t x2;
+- pthread_t x3;
+-
+- memset(&x1, 0x0, sizeof(x1));
+- memset(&x2, 0x0, sizeof(x2));
+- memset(&x3, 0x0, sizeof(x3));
+-
+- __sync_bool_compare_and_swap(&x1, x2, x3);
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_ATOMIC_PTHREAD_T_GCC], [1],
+- [pthread_t can be used by GCC atomic builtins])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+- AC_MSG_CHECKING(whether Solaris libc atomic functions are available)
+- # Define HAVE_IB_SOLARIS_ATOMICS if _all_ of the following
+- # functions are present.
+- AC_CHECK_FUNCS(atomic_add_long_nv \
+- atomic_cas_32 \
+- atomic_cas_64 \
+- atomic_cas_ulong \
+- atomic_swap_uchar)
+-
+- if test "${ac_cv_func_atomic_add_long_nv}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_32}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_64}" = "yes" -a \
+- "${ac_cv_func_atomic_cas_ulong}" = "yes" -a \
+- "${ac_cv_func_atomic_swap_uchar}" = "yes" ; then
+-
+- AC_DEFINE([HAVE_IB_SOLARIS_ATOMICS], [1],
+- [Define to 1 if Solaris libc atomic functions are available]
+- )
+- fi
+-
+- AC_MSG_CHECKING(whether pthread_t can be used by Solaris libc atomic functions)
+- # either define HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS or not
+- AC_TRY_RUN(
+- [
+- #include <pthread.h>
+- #include <string.h>
+-
+- int main(int argc, char** argv) {
+- pthread_t x1;
+- pthread_t x2;
+- pthread_t x3;
+-
+- memset(&x1, 0x0, sizeof(x1));
+- memset(&x2, 0x0, sizeof(x2));
+- memset(&x3, 0x0, sizeof(x3));
+-
+- if (sizeof(pthread_t) == 4) {
+-
+- atomic_cas_32(&x1, x2, x3);
+-
+- } else if (sizeof(pthread_t) == 8) {
+-
+- atomic_cas_64(&x1, x2, x3);
+-
+- } else {
+-
+- return(1);
+- }
+-
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS], [1],
+- [pthread_t can be used by solaris atomics])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-
+ # this is needed to know which one of atomic_cas_32() or atomic_cas_64()
+ # to use in the source
+ AC_CHECK_SIZEOF([pthread_t], [], [#include <pthread.h>])
+
+- # Check for x86 PAUSE instruction
+- AC_MSG_CHECKING(for x86 PAUSE instruction)
+- # We have to actually try running the test program, because of a bug
+- # in Solaris on x86_64, where it wrongly reports that PAUSE is not
+- # supported when trying to run an application. See
+- # http://bugs.opensolaris.org/bugdatabase/printableBug.do?bug_id=6478684
+- # We use ib_ prefix to avoid collisoins if this code is added to
+- # mysql's configure.in.
+- AC_TRY_RUN(
+- [
+- int main() {
+- __asm__ __volatile__ ("pause");
+- return(0);
+- }
+- ],
+- [
+- AC_DEFINE([HAVE_IB_PAUSE_INSTRUCTION], [1], [Does x86 PAUSE instruction exist])
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+ ])
+
+ # vim: set ft=config: