aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-04 16:09:32 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 10:56:37 +0000
commita050b987768b6f8cd40b44aae13716e39b942c96 (patch)
tree247e4b99dbf955338fa737fade1fea672beb9b44 /meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb
parent82b594b205082fa88722805a2f04a4316bf0f922 (diff)
downloadmeta-openembedded-contrib-a050b987768b6f8cd40b44aae13716e39b942c96.tar.gz
mariadb: update to 5.5.41
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb
new file mode 100644
index 0000000000..4ce960d7da
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.5.41.bb
@@ -0,0 +1,19 @@
+require mariadb.inc
+inherit native
+
+PROVIDES += "mysql5-native"
+DEPENDS = "ncurses-native zlib-native bison-native"
+
+RDEPENDS_${PN} = ""
+PACKAGES = ""
+EXTRA_OEMAKE = ""
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+
+ install -d ${D}${bindir}
+ install -m 0755 sql/gen_lex_hash ${D}${bindir}/
+ install -m 0755 extra/comp_err ${D}${bindir}/
+ install -m 0755 scripts/comp_sql ${D}${bindir}/
+}
+