aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-16 18:07:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-16 18:16:29 +0200
commit7f6b98b32b8b3a41607bac0586b862c064f94a9b (patch)
tree26987afaac144c0329e1c0d6883d3a81e77a36bd /meta-oe/recipes-support/multipath-tools
parenta45830a39bb47a9eab27980d52966226c9504ea4 (diff)
downloadmeta-openembedded-contrib-7f6b98b32b8b3a41607bac0586b862c064f94a9b.tar.gz
multipath-tools: move to right place
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
new file mode 100644
index 0000000000..b52b111099
--- /dev/null
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The upstream project used to drive the Device Mapper multipathing driver."
+
+DEPENDS = "lvm2 libaio readline"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
+
+
+SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
+SRCREV = "15fc23ffb2bd1bac6990eda3e23c3e8980e6cfa5"
+
+S = "${WORKDIR}/git"
+
+PV = "0.4.9+git"
+
+EXTRA_OEMAKE = "MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} libdir=${base_libdir}/multipath"
+
+do_install() {
+ oe_runmake install
+}
+
+FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
+FILES_${PN} += "${base_libdir}/multipath \
+ ${base_libdir}/systemd"
+
+PACKAGES =+ "kpartx"
+FILES_kpartx = "${base_sbindir}/kpartx \
+ ${base_libdir}/udev/kpartx_id"
+
+RDEPENDS_${PN} += "kpartx"