aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-02-17 14:14:33 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-20 11:50:14 +0100
commit0557b5e3d0123147f2293b0f49fad611253ece75 (patch)
treeb16531ffd43be1c7a08e013c0e628dd41857133c /meta-oe/recipes-support/multipath-tools
parent72647e2c052b1f59e4a4ed9925d335edcfbf34f7 (diff)
downloadmeta-openembedded-contrib-0557b5e3d0123147f2293b0f49fad611253ece75.tar.gz
multipath-tools: fix ARM build failure
Updating to 0.6.4 introduced a build failure on ARM when thumb was enabled because of the embedded valgrind.h macro calls. The easiest solution and thus the one used here is to disable thumb for this particular recipe for affected machines. The more elaborate solution would be to patch the macro calls out of the code when compiling for ARM with thumb. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
index 6706bec59e..effd92e4eb 100644
--- a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -27,6 +27,14 @@ PV = "0.6.4+git${@'${SRCPV}'.split('+')[-1]}"
TARGET_CC_ARCH += "${LDFLAGS}"
+# multipath-tools includes a copy of the valgrind.h header
+# file and uses the macros to suppress some false positives. However,
+# that only works on ARM when thumb is disabled. Otherwise one gets:
+# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
+# ../Makefile.inc:66: recipe for target 'debug.o' failed
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
# The exact version of SYSTEMD does not matter but should be greater than 209.
#
EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
@@ -59,5 +67,3 @@ FILES_kpartx = "${base_sbindir}/kpartx \
"
RDEPENDS_${PN} += "kpartx"
-
-PNBLACKLIST[multipath-tools] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130529/"