aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2014-09-22 17:22:32 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:54 +0200
commit48e5c5ef39d70c3b00f755d09811f497e6d23f53 (patch)
tree595d81d3ee1e3bc91f1949c5a05f060fa9216712 /meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
parent0a67b9f3fd164b808c66286ff0435c65421e5352 (diff)
downloadmeta-openembedded-contrib-48e5c5ef39d70c3b00f755d09811f497e6d23f53.tar.gz
multipath-tools: update to version 0.5.0+
SCRREV includes patches up to 9/12/2014. Modify upstream source to be better set up for cross compilation. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb58
1 files changed, 49 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
index 038f4e26df..055cfe64c9 100644
--- a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -1,30 +1,70 @@
SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
-DEPENDS = "lvm2 libaio readline"
+DEPENDS = "lvm2 libaio readline udev"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
+LICENSE = "LGPLv2"
+SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
+ file://multipathd.oe \
+ file://makefile_inc.patch \
+ file://always-use-libdevmapper.patch \
+ file://always-use-libdevmapper-kpartx.patch \
+ "
+# 0.5.0
+#
+#SRCREV = "82f391e787dc02e9d9294aa391137ab424bb83c4"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
+
+# 0.5.0 + commits thru 7/18/2014
+#
+#SRCREV = "0d72f46c12207a6b7b89f5ef4f5ab5f87ed8bc90"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
+
+# 0.5.0 + commits thru 9/12/2014
+#
+# includes important systemd related structure size fix
+#
+SRCREV = "aec68ab217fd2956443b27ceeb97dd6475267789"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
+
+inherit systemd
-SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
-SRCREV = "15fc23ffb2bd1bac6990eda3e23c3e8980e6cfa5"
S = "${WORKDIR}/git"
-PV = "0.4.9+git"
+PV = "0.5.0+git${@'${SRCPV}'.split('+')[-1]}"
-EXTRA_OEMAKE = "MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} libdir=${base_libdir}/multipath"
+# The exact version of SYSTEMD does not matter but should be greater than 209.
+#
+EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
+ OPTFLAGS="${CFLAGS}" \
+ LIB=${base_libdir} libdir=${base_libdir}/multipath \
+ unitdir=/lib/systemd/system \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
+ '
do_install() {
oe_runmake install
+
+ # Copy a sample conf file, but do not rename it multipath.conf.
+ #
+ cp multipath.conf.defaults ${D}${sysconfdir}
+
+ # We copy an initscript, but do not start multipathd at init time.
+ #
+ cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
+
}
FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
+
+# systemd and udev stuff always goes under /lib!
+#
FILES_${PN} += "${base_libdir}/multipath \
- ${base_libdir}/systemd"
+ /lib/systemd"
PACKAGES =+ "kpartx"
FILES_kpartx = "${base_sbindir}/kpartx \
- ${base_libdir}/udev/kpartx_id"
+ /lib/udev/kpartx_id"
RDEPENDS_${PN} += "kpartx"