aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mongodb/mongodb_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-02-04 13:52:50 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-18 09:22:39 +0100
commit433c76d221dc77151f15b3427f30ca4f857347e6 (patch)
tree0bc1fb4fd82f277f7865de7f94c00969b18df8ef /meta-oe/recipes-support/mongodb/mongodb_git.bb
parent6d7b3097b4084d5ffdfac0cee2fba2c825a7a827 (diff)
downloadmeta-openembedded-contrib-433c76d221dc77151f15b3427f30ca4f857347e6.tar.gz
mongodb: add git version
This builds the server and the sharding helper, but not the CLI. The CLI will need a libv8 recipe since fixing the built-in copy to cross build is too much work. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mongodb/mongodb_git.bb')
-rw-r--r--meta-oe/recipes-support/mongodb/mongodb_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mongodb/mongodb_git.bb b/meta-oe/recipes-support/mongodb/mongodb_git.bb
new file mode 100644
index 0000000000..f0fe2402ff
--- /dev/null
+++ b/meta-oe/recipes-support/mongodb/mongodb_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "mongodb"
+LICENSE = "AGPLv3 & Apache-2.0"
+LIC_FILES_CHKSUM = "file://GNU-AGPL-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788 \
+ file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "openssl libpcre boost"
+# Mongo uses tcmalloc on x86_64, which is provided by gperftools
+DEPENDS_append_x86-64 = " gperftools"
+
+inherit scons
+
+PV = "2.5.5+git${SRCPV}"
+SRCREV = "588dc81b0822ebb46f80e152b94527a882e6ea5e"
+SRC_URI = "git://github.com/mongodb/mongo.git \
+ file://0001-Make-it-possible-to-disable-the-use-of-v8.patch \
+ file://0002-Fix-linking-when-scripting-is-disabled.patch \
+ file://0003-Do-not-build-mongo-binary-when-scripting-is-disabled.patch \
+ file://0001-replace-os.uname-with-os.getenv-TARGET_ARCH.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+export OE_TARGET_ARCH="${TARGET_ARCH}"
+
+EXTRA_OESCONS = "--prefix=${D}${prefix} \
+ --propagate-shell-environment \
+ --cc-use-shell-environment \
+ --cxx-use-shell-environment \
+ --ld='${TARGET_PREFIX}g++' \
+ --ssl \
+ --use-system-pcre \
+ --use-system-boost \
+ --use-system-tcmalloc \
+ --disable-scripting \
+ --nostrip \
+ mongod mongos"
+
+