aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mg/mg_20170401.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-07 18:24:17 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 11:00:53 +0200
commit0723adbfd6c38377a362338ab23d1ba423c02aaa (patch)
tree4be64753aa3a8e9542e5bdebcbe1c73ec8fb4514 /meta-oe/recipes-support/mg/mg_20170401.bb
parent584d3114ac565c76f968c96463c24277d964fb92 (diff)
downloadmeta-openembedded-contrib-0723adbfd6c38377a362338ab23d1ba423c02aaa.tar.gz
mg: Upgrade to 20170401 release
Fix musl build along the way Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mg/mg_20170401.bb')
-rw-r--r--meta-oe/recipes-support/mg/mg_20170401.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mg/mg_20170401.bb b/meta-oe/recipes-support/mg/mg_20170401.bb
new file mode 100644
index 0000000000..dad1d008bf
--- /dev/null
+++ b/meta-oe/recipes-support/mg/mg_20170401.bb
@@ -0,0 +1,37 @@
+SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
+HOMEPAGE = "http://homepage.boetes.org/software/mg/"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://version.c;md5=1895eb37bf6bd79cdc5c89d8166fabfb"
+DEPENDS = "ncurses libbsd"
+SECTION = "console/editors"
+
+SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
+ file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \
+ file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \
+ "
+SRC_URI_append_libc-musl = "\
+ file://0001-Undefine-REGEX-for-musl-based-systems.patch \
+ "
+SRC_URI[md5sum] = "884388589fb38c2109ad9fed328be20a"
+SRC_URI[sha256sum] = "0a3608b17c153960cb1d954ca3b62445a77c0c1a18aa5c8c58aba9f6b8d62aab"
+
+# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'LDFLAGS=${LDFLAGS}' \
+ \
+ 'prefix=${prefix}' \
+ 'bindir=${bindir}' \
+ 'libdir=${libdir}' \
+ 'includedir=${includedir}' \
+ 'mandir=${mandir}' \
+ 'PKG_CONFIG=pkg-config' \
+"
+
+CFLAGS += "-I${STAGING_INCDIR}/bsd"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+inherit pkgconfig