aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/maliit/maliit-framework_git.bb
diff options
context:
space:
mode:
authorSamuel Stirtzel <s.stirtzel@googlemail.com>2013-04-04 08:18:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-09 21:34:15 +0200
commitc35842efb2bd9b6df13f58afea9f1a7c04d8d769 (patch)
tree02ae9b9872de94e0936fd9c40bb951821ffd132f /meta-oe/recipes-support/maliit/maliit-framework_git.bb
parentb07f0a239e7ee2b81157399b6befa811a5009813 (diff)
downloadmeta-openembedded-contrib-c35842efb2bd9b6df13f58afea9f1a7c04d8d769.tar.gz
maliit-framework: fix for Qt applications
fixes a linking issue and also sets the required variable for X based programms Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/maliit/maliit-framework_git.bb')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
index a164e781fa..e61cca028c 100644
--- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -10,6 +10,7 @@ inherit autotools qt4x11 gtk-immodules-cache
SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \
+ file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \
"
SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
@@ -65,4 +66,25 @@ do_install_append() {
sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf
}
-S= "${WORKDIR}/git"
+pkg_postinst_${PN} () {
+#!/bin/sh
+# should run online
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
+}
+
+pkg_postrm_${PN} () {
+#!/bin/sh
+# should run online
+if [ "x$D" = "x" ]; then
+ exit 1
+fi
+if [ -e "/etc/xprofile" ]; then
+ sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+fi
+
+}
+
+S = "${WORKDIR}/git"