aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/logwarn
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-09 14:40:32 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-14 14:51:16 +0200
commit6c735319a4a6a8e7698b730e36b49f73cf95a6fc (patch)
treea3814817f1d2f726b5a331277efe247744c21f3e /meta-oe/recipes-support/logwarn
parenta5b7f49d7f35328282fd9d906d55bced26e0f8cb (diff)
downloadmeta-openembedded-contrib-6c735319a4a6a8e7698b730e36b49f73cf95a6fc.tar.gz
logwarn: add new recipe
logwarn is a utility for finding interesting messages in log files. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/logwarn')
-rw-r--r--meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb
new file mode 100644
index 0000000000..00e5d497b3
--- /dev/null
+++ b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb
@@ -0,0 +1,46 @@
+SUMMARY = "A utility for finding interesting messages in log files"
+DESCRIPTION = "Logwarn searches for interesting messages in log files, \
+ where 'interesting' is defined by a user-supplied list of positive and \
+ negative extended regular expressions. \
+"
+HOMEPAGE = "https://github.com/archiecobbs/logwarn/wiki"
+SECTION = "console/utils"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "https://s3.amazonaws.com/archie-public/${BPN}/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "e544a6230673ea54f7430bf817bb39d8"
+SRC_URI[sha256sum] = "8dbfcf9b28c782ab3bddd6a620d4fb95d1b0ffcbe93276996cdc4800aa9aebd1"
+
+inherit autotools-brokensep
+
+# This directory is NOT volatile.
+#
+lcl_default_state_dir = "${localstatedir}/lib/logwarn"
+
+CFLAGS += '-DDEFAULT_STATE_DIR=\""${lcl_default_state_dir}\""'
+
+
+# Make sure some files exist for autoreconf.
+#
+do_configure_prepend () {
+ touch ${S}/NEWS
+ touch ${S}/ChangeLog
+ touch ${S}/README
+}
+
+# Create a directory for logfile state info, usually under /var/lib.
+#
+do_install_append () {
+ install -d ${D}${lcl_default_state_dir}
+}
+
+# Make a package for the nagios plug-in (script).
+#
+PACKAGES += "${PN}-nagios"
+
+FILES_${PN}-nagios = "${nonarch_libdir}/nagios"
+
+RDEPENDS_${PN}-nagios += "bash"